#25879 closed defect (fixed)

Residue incorrect for extensions of CA and FM extensions

Reported by: saraedum Owned by:
Priority: major Milestone: sage-8.4
Component: padics Keywords:
Cc: roed, xcaruso Merged in:
Authors: Julian Rüth Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: 5917d5d (Commits) Commit: 5917d5d7daedd95f0bd1e30873eb0f5842694148
Dependencies: Stopgaps:

Description (last modified by saraedum)

This has been reported on sage-devel recently:

sage: K = ZpCA(3,5)
sage: R.<a> = K[]
sage: L.<a> = K.extension(a^2 - 3)
sage: a.residue()
1

Change History (9)

comment:1 Changed 23 months ago by saraedum

  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 23 months ago by saraedum

The issue seems to be in expansion(n):

sage: a.expansion()
[0, 1]
sage: a.expansion(0)
1

The problem is a line that says:

return ulist[n - self.ordp]

Here the index is negative in our case (n=0, self.ordp=1)

comment:3 Changed 23 months ago by saraedum

  • Branch set to u/saraedum/25879

comment:4 Changed 23 months ago by saraedum

  • Authors set to Julian Rüth
  • Cc roed xcaruso added
  • Commit set to ff8e3f43bd437159be23fd35ec9289fbe2bd36d5
  • Description modified (diff)

New commits:

ff8e3f4Port expansion fix from CR to CA and FM

comment:5 Changed 23 months ago by git

  • Commit changed from ff8e3f43bd437159be23fd35ec9289fbe2bd36d5 to 5917d5d7daedd95f0bd1e30873eb0f5842694148

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

5917d5dPort expansion fix from CR to CA and FM

comment:6 Changed 23 months ago by saraedum

  • Status changed from new to needs_review
  • Work issues set to is the patchbot happy?

New commits:

5917d5dPort expansion fix from CR to CA and FM

comment:7 Changed 23 months ago by chapoton

  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

let it be

comment:8 Changed 23 months ago by saraedum

  • Work issues is the patchbot happy? deleted

comment:9 Changed 22 months ago by vbraun

  • Branch changed from u/saraedum/25879 to 5917d5d7daedd95f0bd1e30873eb0f5842694148
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.