Opened 4 years ago

Closed 4 years ago

#25687 closed enhancement (fixed)

py3: various fixes about range, map, filter

Reported by: Frédéric Chapoton Owned by:
Priority: major Milestone: sage-8.3
Component: python3 Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 6cc68f2 (Commits, GitHub, GitLab) Commit: 6cc68f2c146650eb07db5e5bcc027ed5149c8951
Dependencies: Stopgaps:

Status badges

Description


Change History (7)

comment:1 Changed 4 years ago by Frédéric Chapoton

Branch: u/chapoton/25687
Commit: f3db12de20bfe6b12a48812db5c4f620228501b8
Status: newneeds_review

New commits:

f3db12dpy3: various fixes, about range, map, filter

comment:2 Changed 4 years ago by git

Commit: f3db12de20bfe6b12a48812db5c4f620228501b86cc68f2c146650eb07db5e5bcc027ed5149c8951

Branch pushed to git repo; I updated commit sha1. New commits:

6cc68f2one fix

comment:3 Changed 4 years ago by Travis Scrimshaw

There are a bunch of "failed to compute analytic rank" on the patchbot report. Are those ignorable?

comment:4 Changed 4 years ago by Frédéric Chapoton

no, they should be taken care of. Cause by the change in src/sage/modular/btquotients/btquotient.py probably. This is a very touchy file... Not the first time that I had to withdraw my changes there.

comment:5 Changed 4 years ago by Frédéric Chapoton

or maybe not.. I am not able to reproduce them. And I do not see how this could come from my changes, which I have double-checked, and are all innocuous enough.

So they can probably be ignored. I will try to run my own patchbots on that.

comment:6 Changed 4 years ago by Travis Scrimshaw

Reviewers: Travis Scrimshaw
Status: needs_reviewpositive_review

I remember seeing them on other tickets and could be ignored there. I have no idea what causes them; they seem to be more transient failures (I am also unable to reproduce them). I thought I would check just to be sure.

comment:7 Changed 4 years ago by Volker Braun

Branch: u/chapoton/256876cc68f2c146650eb07db5e5bcc027ed5149c8951
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.