Opened 4 years ago

Closed 3 years ago

#25615 closed defect (invalid)

1 internet doctest failing in combinat/designs/ext_rep.py

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

With 8.3.beta6,

$ sage -t --long --optional=sage,internet src/sage/combinat/designs/ext_rep.py

gives:

sage -t --long src/sage/combinat/designs/ext_rep.py
**********************************************************************
File "src/sage/combinat/designs/ext_rep.py", line 557, in sage.combinat.designs.ext_rep.open_extrep_url
Failed example:
    s = ext_rep.designs_from_XML_url("http://designtheory.org/database/v-b-k/v3-b6-k2.icgsa.txt.bz2") # optional - internet
Exception raised:
    Traceback (most recent call last):
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 573, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 983, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.combinat.designs.ext_rep.open_extrep_url[7]>", line 1, in <module>
        s = ext_rep.designs_from_XML_url("http://designtheory.org/database/v-b-k/v3-b6-k2.icgsa.txt.bz2") # optional - internet
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/sage/combinat/designs/ext_rep.py", line 1062, in designs_from_XML_url
        s = open_extrep_url(url)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/sage/combinat/designs/ext_rep.py", line 560, in open_extrep_url
        f = urlopen(url)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 154, in urlopen
        return opener.open(url, data, timeout)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 429, in open
        response = self._open(req, data)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 447, in _open
        '_open', req)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 407, in _call_chain
        result = func(*args)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 1228, in http_open
        return self.do_open(httplib.HTTPConnection, req)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/urllib2.py", line 1201, in do_open
        r = h.getresponse(buffering=True)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/httplib.py", line 1121, in getresponse
        response.begin()
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/httplib.py", line 438, in begin
        version, status, reason = self._read_status()
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/httplib.py", line 394, in _read_status
        line = self.fp.readline(_MAXLINE + 1)
      File "/home/slabbe/GitBox/sage/local/lib/python2.7/socket.py", line 482, in readline
        data = self._sock.recv(self._rbufsize)
    error: [Errno 104] Connection reset by peer
**********************************************************************
1 item had failures:
   1 of   9 in sage.combinat.designs.ext_rep.open_extrep_url
    [102 tests, 1 failure, 3.77 s]
----------------------------------------------------------------------
sage -t --long src/sage/combinat/designs/ext_rep.py  # 1 doctest failed
----------------------------------------------------------------------
Total time for all tests: 3.9 seconds
    cpu time: 0.3 seconds
    cumulative wall time: 3.8 seconds
External software detected for doctesting: internet

Change History (6)

comment:1 Changed 4 years ago by chapoton

This is working for me in 8.3.rc1. Maybe an issue with your machine only ?

comment:2 Changed 4 years ago by slabbe

With 8.3.rc1 on Ubuntu 16.04, I did 10 times:

sage -t --long --optional=sage,internet src/sage/combinat/designs/ext_rep.py

I am able to reproduce the failure on the first run. I get no failure on the next 9 ones. Weird.

comment:3 Changed 4 years ago by slabbe

  • Milestone changed from sage-8.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

With 8.4.beta1, I am unable to reproduce the error. I get:

$ sage -t --long --optional=sage,internet src/sage/combinat/designs/ext_rep.py
too many failed tests, not using stored timings
Running doctests with ID 2018-08-22-14-38-07-0c642eab.
Git branch: develop
Using --optional=internet,sage
Doctesting 1 file.
sage -t --long src/sage/combinat/designs/ext_rep.py
    [102 tests, 0.55 s]
----------------------------------------------------------------------
All tests passed!
----------------------------------------------------------------------
Total time for all tests: 0.6 seconds
    cpu time: 0.3 seconds
    cumulative wall time: 0.6 seconds

I agree to close this ticket.

comment:4 Changed 4 years ago by chapoton

  • Status changed from needs_review to positive_review

ok

comment:5 Changed 3 years ago by slabbe

As constantly reported in sage-release, I am still and always having this issue each time I run

sage -tp --all --long --optional=sage,optional,external

But I am not able to reproduce it when run as below:

sage -t --long -optional=sage,optional,external src/sage/combinat/designs/ext_rep.py

Strange no?

comment:6 Changed 3 years ago by embray

  • Resolution set to invalid
  • Status changed from positive_review to closed

Presuming these are all correctly reviewed as either duplicate, invalid, or wontfix.

Note: See TracTickets for help on using tickets.