Opened 5 years ago

Last modified 7 weeks ago

#25536 new task

meta-ticket: failing internet/optional doctests

Reported by: Sébastien Labbé Owned by:
Priority: major Milestone: sage-pending
Component: doctest coverage Keywords: meta-ticket, internet, optional doctests, thursdaysbdx
Cc: Samuel Lelièvre, vklein, Thierry Monteil Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Sébastien Labbé)

This meta-ticket lists tickets opened for failing doctests involving internet, optional and/or external packages as discovered by running:

sage -tp --optional=sage,optional,external --all

Many issues are related to internet (running them is activated by the tag external in the above command) which can be specifically tested with the following command:

sage -tp --optional=sage,internet --all

Tickets

Still open tickets:

  • #34683 1 internet doctest failing in repl/interpreter.py
  • #31475 1 internet doctest failing in src/sage/tests/cmdline.py - ore_algebra version
  • #32294 Fix failing doctests with optional package gap_packages
  • #32697 1 pandoc optional doctest failing in src/sage/tests/cmdline.py

Failing doctests maybe related to the presence of an optional package:

  • #32053 1 doctest failing in combinat/designs/incidence_structures.py

Fixed in 9.8:

  • #34607 2 doctests failures with external software octave
  • #34609 5 internet doctests failing in oeis
  • #34612 1 internet doctest failing in graphs/isgci.py
  • #34594: fix failure in latex.py: latex plus latex_package_tkz_graph
  • #34595: find findstat internet failures
  • #32051 1 internet doctest failing in src/sage/misc/package.py
  • #30635 doctests failures in sage/graphs when using COIN solver
  • #33093 5 doctests failing related to external program octave

Fixed in 9.7:

  • #33943 1 doctest failing in oeis.py

Fixed in 9.6:

  • #33588 15 GLPK doctests failing because "Long-step dual simplex will be used" gets printed
  • #33179 fix some optional internet u-prefix doctests in oeis, findstat, matematica

Fixed in 9.5:

  • #33162 Fix installation of cryptominisat and pycryptosat + doctests failings in 6 files
  • #32694 9 internet doctests failing in src/sage/databases/findstat.py
  • #32740 2 glucose doctests failing in sage/sat/solvers/dimacs.py
  • #32886 1 fricas optional doctest failing in interfaces/fricas.py
  • #32885 9 internet doctests failing in tests/cmdline.py - AttributeError: can't set attribute
  • #32696 1 internet doctest failing in src/sage/finance/stock.py
  • #32695 5 internet doctests failing in src/sage/databases/oeis.py
  • #32693 1 internet failing doctest in src/sage/calculus/calculus.py
  • #32050 2 internet doctest failing in oeis.py
  • #32290 Fix polytopes_db_4d optional doctest

Fixed in 9.4:

  • #32052 5 failing doctests in src/sage/graphs (duplicate of #30635)
  • #31756 regression: conversion of Mathematica's Sqrt to Sage fails
  • #31865 1 internet doctests failing in symbolic/integration/external.py
  • #31866 3 internet doctests failing in oeis.py

Fixed in 9.3:

  • #31054 2 internet doctests failing in findstat.py
  • #31023 2 internet doctests failing in findstat.py and oeis.py
  • #30630 internet findstat error handling
  • #30633 sympow gives "RuntimeError: failed to compute analytic rank" doctest failures
  • #30636 failing doctest with optional tag octave
  • #30637 doctest failing in designs/incidence_structures.py

Fixed in 9.2:

  • #30632 few easy internet doctests failures to fix
  • #30634 failing internet doctests using mathematica free
  • #30638 internet doctest failing in arith/misc.py
  • #28864 internet doctests failing in findstat.py
  • #30131 2 internet doctests failing in bibd.py
  • #30138 1 internet doctest failing in oeis.py (cross_references)
  • #30020 3 internet oeis doctests failing in combinat
  • #30019 1 internet doctest failing in combinat/quickref.py
  • #29787 1 optional internet oeis doctest failing (busy beaver ordering)
  • #25465 2 doctests failed in smallgraphs.py (a duplicate was #28865)

Fixed in 9.1:

  • #29579 1 internet test failing in OEIS
  • #29578 1 internet test failing in symbolic/integration/external.py
  • #28866 doctest killed due to abort in geometry/polyhedron/base.py
  • #28868 7 imagemagick failing doctests in plot/animate.py
  • #29237 1 optional internet oeis doctest failing in combinat/tutorial.py
  • #29300 Latte test failure
  • #28867 1 imagemagick failing doctest in misc/latex.py
  • #29047 1 internet doctest failing in repl/load.py
  • #29048 1 internet doctest failing in src/sage/databases/oeis.py

Fixed in 9.0:

  • #28708 5 cplex doctests failed in cplex_backend.pyx
  • #28700 missing latte_int optional tag in three doctests (a duplicate ticket was #28697)
  • #27838 5 (now 8) internet doctests failing in findstat.py
  • #28689 fix doctests with cbc
  • #28756 py3: fix doctests with gurobi
  • #28759 py3: dot2tex + graphviz doctests failures
  • #28760 py3: imagemagick,internet,latex str vs bytes doctests failures
  • #28761 py3: further fixes for misc relative to internet doctests failures
  • #28763 7 glucose optional doctests failed in sat/solvers/dimacs.py
  • #28764 2 internet doctest failed in hadamard_matrix.py
  • #28762 2 doctests failed in cmdline.py related to rst2ipynb
  • #28808 failing internet in repl/load.py
  • #28863 1 doctest failed in thematic_tutorials/linear_programming.rst because of CPLEX

Fixed in 8.9:

  • #28455 1 doctest failing in src/sage/databases/oeis.py with tag internet
  • #28127 1 internet doctest failing in oeis.py (Avogadro's)
  • #28206 py3: fix str vs bytes issues with gurobi

Fixed in 8.8:

  • #27872 2 failing trivial internet doctests related to oeis
  • #27821 failing internet doctests in sage/combinat/designs (again)
  • #27783 6 doctests internet failed in databases/oeis.py
  • #27782 1 pynormaliz doctest failing in geometry/polyhedron/backend_normaliz.py
  • #27781 2 internet doctests failing in misc/package.py
  • #26592 3+2 failing internet doctests in sage/combinat/designs

Fixed in 8.7:

  • #25614 2 failing internet doctests in sage/misc/persist.pyx
  • #27361 oeis.py related to internet
  • #27249 fix doctest in graph_latex related to dot2tex and graphviz
  • #25535 1 failing internet doctest in sage/repl/load.py
  • #27172 1 optional doctest failing in cmdline.py related to pandoc
  • #26997 5 internet doctests failing in findstat.py
  • #26999 1 optional gurobi doctest failing

Fixed in 8.6:

  • #26921 1 internet doctest failing in combinat/tutorial.py
  • #25501 3+1 internet failing doctests in sage/symbolic/integration/external.py and internal.py, because of mma_free_integrator is broken, thus also fixing #14764
  • #26920 -> #26994 (2 failing doctests in sql_db.py because of optional pkg bliss)

Fixed in 8.5:

  • #25473 20 failing internet doctests in finance/stock.py
  • #26348 3 other internet doctests failures in findstat.py
  • #26502 3+2 failing internet doctests in sage/combinat/designs
  • #26728: Remove ellipsis in one findstat doctest

Fixed in 8.4:

  • #25773 (1 more internet in findstat)
  • #26125 (3 more internet in oeis)
  • #25378 (I/O on closed file error when running doctest with external packages)
  • #26347 (animate.py and paths.py related to external ffmpeg and imagemagick)

Fixed in 8.3:

  • #25471 (oeis)
  • #25472 (findstat)
  • #25474 (6 files)
  • #25534 (coding/databases.py)
  • #25416 (failures in animate.py related to external package imagemagick)
  • #25399 (failures related to optional package bliss)

Closed as invalid because not always reproducible:

  • #25615 1 internet doctest failing in sage/combinat/designs/ext_rep.py

Reports

Many of the above tickets originated in reports of failing doctests on the sage-release mailing list, after the release announcement for various development versions of Sage. See for instance:

and more can be found by searching for "internet" on sage-release.

Change History (124)

comment:1 Changed 5 years ago by Sébastien Labbé

I fixed #25474. I am clueless for the others.

comment:2 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

added persist.pyx

comment:3 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:4 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)
Summary: meta-ticket: failing internet doctests in 8.3.beta3meta-ticket: failing internet doctests in 8.3.betaX

comment:5 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:6 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:7 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:8 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)
Summary: meta-ticket: failing internet doctests in 8.3.betaXmeta-ticket: failing internet/optional doctests in 8.3.betaX and 8.4.betaX

comment:9 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:10 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:11 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:12 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:13 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:14 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:15 Changed 4 years ago by Samuel Lelièvre

Cc: Samuel Lelièvre added

See also

  • #26728: Remove ellipsis in one findstat doctest

comment:16 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)
Summary: meta-ticket: failing internet/optional doctests in 8.3.betaX and 8.4.betaXmeta-ticket: failing internet/optional doctests in 8.3.betaX, 8.4.betaX, 8.5.betaX

comment:17 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:18 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:19 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:20 Changed 4 years ago by Jeroen Demeyer

Summary: meta-ticket: failing internet/optional doctests in 8.3.betaX, 8.4.betaX, 8.5.betaXmeta-ticket: failing internet/optional doctests

comment:21 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:22 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:23 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:24 Changed 4 years ago by Samuel Lelièvre

Description: modified (diff)
Keywords: meta-ticket internet optional doctests added
Milestone: sage-8.3sage-pending

comment:25 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:26 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:27 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:28 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:29 Changed 4 years ago by Sébastien Labbé

Cc: vklein added
Description: modified (diff)

comment:30 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)
Keywords: thursdaysbdx added

comment:31 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:32 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:33 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:34 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:35 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:36 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:37 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:38 Changed 4 years ago by Sébastien Labbé

Description: modified (diff)

comment:39 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:40 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:41 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:42 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

adding #28697

comment:43 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:44 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:45 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:46 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:47 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:48 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:49 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:50 Changed 3 years ago by David Coudert

Description: modified (diff)

comment:51 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

tickets merged in 9.0.beta8

comment:52 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:53 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:54 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:55 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:56 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:57 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:58 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:59 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:60 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:61 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:62 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:63 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:64 Changed 3 years ago by Karl-Dieter Crisman

Description: modified (diff)

comment:65 Changed 3 years ago by Karl-Dieter Crisman

Description: modified (diff)

comment:66 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:67 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:68 Changed 3 years ago by Sébastien Labbé

Description: modified (diff)

comment:69 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:70 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:71 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:72 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:73 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:74 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:75 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:76 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:77 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:78 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:79 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:80 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:81 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:82 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:83 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:84 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:85 Changed 2 years ago by Sébastien Labbé

Description: modified (diff)

comment:86 Changed 22 months ago by Sébastien Labbé

Description: modified (diff)

comment:87 Changed 21 months ago by Sébastien Labbé

Description: modified (diff)

comment:88 Changed 19 months ago by Sébastien Labbé

Description: modified (diff)

comment:89 Changed 19 months ago by Sébastien Labbé

Description: modified (diff)

comment:90 Changed 19 months ago by Sébastien Labbé

Description: modified (diff)

comment:91 Changed 19 months ago by Sébastien Labbé

Description: modified (diff)

comment:92 Changed 18 months ago by Sébastien Labbé

Description: modified (diff)

comment:93 Changed 17 months ago by Matthias Köppe

Would it make sense to enable the optional=internet doctests for our automatic tests on GitHub Actions? Or would there be concern that it causes too much network traffic?

comment:94 Changed 17 months ago by Samuel Lelièvre

Description: modified (diff)

comment:95 Changed 17 months ago by Samuel Lelièvre

Description: modified (diff)

comment:96 Changed 15 months ago by Matthias Köppe

Cc: Thierry Monteil added

comment:97 in reply to:  93 Changed 15 months ago by Thierry Monteil

Replying to mkoeppe:

Would it make sense to enable the optional=internet doctests for our automatic tests on GitHub Actions? Or would there be concern that it causes too much network traffic?

Sage relies on small public online services such as oeis or findstat. It is unfair to connect to their server at each doctest. Most failing internet doctests are due to some changes on the remote servers (e.g. when they fix a typo or when they add a line of documentation) and are not errors in the Sage library.

comment:98 Changed 15 months ago by Matthias Köppe

I think this needs some quantitative context. The tests on GH Actions run automatically on every release tag (or when a developer manually triggers a CI run by clicking a button or pushing a tag). They do not run on every ticket (or every commit). On every run, around 100 copies of make ptest are launched. I don't know whether this would be out of proportion traffic for these services.

comment:99 Changed 15 months ago by Samuel Lelièvre

Failures of our internet tests usually signal changes in the online services we connect to, and are not platform-dependent, so one run of these tests per release suffices -- no need for a hundred.

comment:100 Changed 14 months ago by Sébastien Labbé

Description: modified (diff)

updated tickets merged in 9.5

comment:101 Changed 14 months ago by Sébastien Labbé

Description: modified (diff)

Adding 5 new tickets to the list (failures with 9.5.beta3)

comment:102 Changed 14 months ago by Sébastien Labbé

Description: modified (diff)

1 merged ticket + 1 new ticket (glucose)

comment:103 Changed 13 months ago by Sébastien Labbé

Description: modified (diff)

comment:104 Changed 13 months ago by Sébastien Labbé

Description: modified (diff)

comment:105 Changed 13 months ago by Sébastien Labbé

Description: modified (diff)

comment:106 Changed 13 months ago by Sébastien Labbé

Description: modified (diff)

comment:107 Changed 12 months ago by Sébastien Labbé

Description: modified (diff)

comment:108 Changed 11 months ago by Sébastien Labbé

Description: modified (diff)

tickets merged in 9.5.beta9

comment:109 Changed 11 months ago by Sébastien Labbé

Description: modified (diff)

comment:110 Changed 11 months ago by Sébastien Labbé

Description: modified (diff)

comment:111 Changed 11 months ago by Sébastien Labbé

Description: modified (diff)

comment:112 Changed 10 months ago by Sébastien Labbé

Description: modified (diff)

one ticket merged in 9.6

comment:113 Changed 8 months ago by Sébastien Labbé

Description: modified (diff)

comment:114 Changed 7 months ago by Sébastien Labbé

Description: modified (diff)

ticket fixed in 9.6

comment:115 Changed 6 months ago by Sébastien Labbé

Description: modified (diff)

comment:116 Changed 6 months ago by Sébastien Labbé

Description: modified (diff)

comment:117 Changed 2 months ago by John Palmieri

Description: modified (diff)

comment:118 Changed 2 months ago by John Palmieri

Description: modified (diff)

comment:119 Changed 2 months ago by John Palmieri

Description: modified (diff)

comment:120 Changed 2 months ago by Sébastien Labbé

Description: modified (diff)

comment:121 Changed 2 months ago by Sébastien Labbé

Description: modified (diff)

comment:122 Changed 2 months ago by Sébastien Labbé

Description: modified (diff)

comment:123 Changed 2 months ago by Sébastien Labbé

Description: modified (diff)

tickets merged in 9.8.beta1

comment:124 Changed 7 weeks ago by Sébastien Labbé

Description: modified (diff)

tickets merged in 9.8.beta2

Note: See TracTickets for help on using tickets.