Opened 4 years ago

Last modified 22 months ago

#25503 closed defect

Allow the use of system's R installation — at Initial Version

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: R, sdl
Cc: charpent, embray, fbissey, kcrisman, slelievre, gh-timokau, mjo Merged in:
Authors: Thierry Monteil Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The aim of this ticket is to allow Sage to use the system's R, instead of building its own.

It should work for:

  • sage -R command
  • Sage's r interface
  • Sage's rpy2 Python package
  • Sage's jupyter IRkernel

As for atlas, it is done by setting the SAGE_R_LIB environment variable.

Change History (0)

Note: See TracTickets for help on using tickets.