Opened 3 years ago

Closed 3 years ago

#25475 closed defect (duplicate)

Few doctests failed in sage/geometry

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: geometry Keywords:
Cc: Merged in:
Authors: Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As reported on sage-release 8.3.beta3,

sage -tp --long src/sage/geometry/polyhedron/base.py src/sage/geometry/lattice_polytope.py src/sage/geometry/triangulation/point_configuration.py src/sage/geometry/polyhedron/ppl_lattice_polytope.py src/sage/geometry/fan_isomorphism.py

gives

Running doctests with ID 2018-05-30-23-09-29-4fce6fcc.
Git branch: develop
Using --optional=bliss,ccache,mpir,python2,sage
Doctesting 5 files using 8 threads.
sage -t --long src/sage/geometry/fan_isomorphism.py
**********************************************************************
File "src/sage/geometry/fan_isomorphism.py", line 84, in sage.geometry.fan_isomorphism.fan_isomorphism_generator
Failed example:
    tuple( fan_isomorphism_generator(fan, fan) )
Expected:
    (
    [1 0]  [0 1]  [ 1  0]  [ 0  1]  [-1 -1]  [-1 -1]
    [0 1], [1 0], [-1 -1], [-1 -1], [ 1  0], [ 0  1]
    )
Got:
    (
    [1 0]  [0 1]  [-1 -1]  [-1 -1]  [ 0  1]  [ 1  0]
    [0 1], [1 0], [ 0  1], [ 1  0], [-1 -1], [-1 -1]
    )
**********************************************************************
1 item had failures:
   1 of  21 in sage.geometry.fan_isomorphism.fan_isomorphism_generator
    [65 tests, 1 failure, 1.30 s]
sage -t --long src/sage/geometry/lattice_polytope.py
**********************************************************************
File "src/sage/geometry/lattice_polytope.py", line 3067, in sage.geometry.lattice_polytope.LatticePolytopeClass._palp_PM_max
Failed example:
    all(len(i) == len(j.automorphisms_of_rows_and_columns())
        for j, i in PMs) # long time
Expected:
    True
Got:
    False
**********************************************************************
1 item had failures:
   1 of  12 in sage.geometry.lattice_polytope.LatticePolytopeClass._palp_PM_max
    [638 tests, 1 failure, 17.17 s]
sage -t --long src/sage/geometry/polyhedron/ppl_lattice_polytope.py
**********************************************************************
File "src/sage/geometry/polyhedron/ppl_lattice_polytope.py", line 985, in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.restricted_automorphism_group
Failed example:
    Z3square.restricted_automorphism_group(vertex_labels=(1,2,3,4))
Expected:
    Permutation Group with generators [(2,3), (1,2)(3,4), (1,4)]
Got:
    Permutation Group with generators [(2,3), (1,2)(3,4)]
**********************************************************************
File "src/sage/geometry/polyhedron/ppl_lattice_polytope.py", line 987, in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.restricted_automorphism_group
Failed example:
    G = Z3square.restricted_automorphism_group(); G
Expected:
    Permutation Group with generators [((1,2),(2,1)),
    ((0,0),(1,2))((2,1),(3,3)), ((0,0),(3,3))]
Got:
    Permutation Group with generators [((0,0),(3,3)), ((1,2),(0,0))((3,3),(2,1))]
**********************************************************************
File "src/sage/geometry/polyhedron/ppl_lattice_polytope.py", line 990, in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.restricted_automorphism_group
Failed example:
    tuple(G.domain()) == Z3square.vertices()
Expected:
    True
Got:
    False
**********************************************************************
File "src/sage/geometry/polyhedron/ppl_lattice_polytope.py", line 992, in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.restricted_automorphism_group
Failed example:
    G.orbit(Z3square.vertices()[0])
Expected:
    ((0, 0), (1, 2), (3, 3), (2, 1))
Got:
    ((0, 0), (3, 3), (1, 2), (2, 1))
**********************************************************************
File "src/sage/geometry/polyhedron/ppl_lattice_polytope.py", line 1063, in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.lattice_automorphism_group
Failed example:
    G2 = Z3square.restricted_automorphism_group(vertex_labels=(1,2,3,4)); G2
Expected:
    Permutation Group with generators [(2,3), (1,2)(3,4), (1,4)]
Got:
    Permutation Group with generators [(2,3), (1,2)(3,4)]
**********************************************************************
2 items had failures:
   1 of  13 in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.lattice_automorphism_group
   4 of   9 in sage.geometry.polyhedron.ppl_lattice_polytope.LatticePolytope_PPL_class.restricted_automorphism_group
    [173 tests, 5 failures, 12.73 s]
sage -t --long src/sage/geometry/triangulation/point_configuration.py
**********************************************************************
File "src/sage/geometry/triangulation/point_configuration.py", line 1155, in sage.geometry.triangulation.point_configuration.PointConfiguration.restricted_automorphism_group
Failed example:
    pyramid.restricted_automorphism_group()
Expected:
    Permutation Group with generators [(3,5), (2,3)(4,5), (2,4)]
Got:
    Permutation Group with generators [(3,5), (2,3)(4,5)]
**********************************************************************
1 item had failures:
   1 of   7 in sage.geometry.triangulation.point_configuration.PointConfiguration.restricted_automorphism_group
    [204 tests, 1 failure, 21.29 s]
sage -t --long src/sage/geometry/polyhedron/base.py
**********************************************************************
File "src/sage/geometry/polyhedron/base.py", line 5747, in sage.geometry.polyhedron.base.Polyhedron_base.restricted_automorphism_group
Failed example:
    P.restricted_automorphism_group()
Expected:
    Permutation Group with generators [(3,4), (2,3)(4,5), (2,5), (1,2)(5,6), (1,6)]
Got:
    Permutation Group with generators [(3,4), (2,3)(4,5), (1,2)(5,6)]
**********************************************************************
File "src/sage/geometry/polyhedron/base.py", line 5749, in sage.geometry.polyhedron.base.Polyhedron_base.restricted_automorphism_group
Failed example:
    P.restricted_automorphism_group(output="permutation")
Expected:
    Permutation Group with generators [(2,3), (1,2)(3,4), (1,4), (0,1)(4,5), (0,5)]
Got:
    Permutation Group with generators [(2,3), (1,2)(3,4), (0,1)(4,5)]
**********************************************************************
File "src/sage/geometry/polyhedron/base.py", line 5751, in sage.geometry.polyhedron.base.Polyhedron_base.restricted_automorphism_group
Failed example:
    P.restricted_automorphism_group(output="matrix")
Expected:
    Matrix group over Rational Field with 5 generators (
    [ 1  0  0  0]  [1 0 0 0]  [ 1  0  0  0]  [0 1 0 0]  [-1  0  0  0]
    [ 0  1  0  0]  [0 0 1 0]  [ 0 -1  0  0]  [1 0 0 0]  [ 0  1  0  0]
    [ 0  0 -1  0]  [0 1 0 0]  [ 0  0  1  0]  [0 0 1 0]  [ 0  0  1  0]
    [ 0  0  0  1], [0 0 0 1], [ 0  0  0  1], [0 0 0 1], [ 0  0  0  1]
    )
Got:
    Matrix group over Rational Field with 3 generators (
    [ 1  0  0  0]  [1 0 0 0]  [0 1 0 0]
    [ 0  1  0  0]  [0 0 1 0]  [1 0 0 0]
    [ 0  0 -1  0]  [0 1 0 0]  [0 0 1 0]
    [ 0  0  0  1], [0 0 0 1], [0 0 0 1]
    )
**********************************************************************
File "src/sage/geometry/polyhedron/base.py", line 5763, in sage.geometry.polyhedron.base.Polyhedron_base.restricted_automorphism_group
Failed example:
    PermutationGroup([
        '(1,20,2,24,5,23)(3,18,10,19,4,14)(6,21,11,22,7,15)(8,12,16,17,13,9)',
        '(1,21,8,24,4,17)(2,11,6,15,9,13)(3,20)(5,22)(10,16,12,23,14,19)'
    ]) == AutP24
Expected:
    True
Got:
    False
**********************************************************************
1 item had failures:
   4 of  40 in sage.geometry.polyhedron.base.Polyhedron_base.restricted_automorphism_group
    [1008 tests, 4 failures, 30.52 s]
----------------------------------------------------------------------
sage -t --long src/sage/geometry/fan_isomorphism.py  # 1 doctest failed
sage -t --long src/sage/geometry/lattice_polytope.py  # 1 doctest failed
sage -t --long src/sage/geometry/polyhedron/ppl_lattice_polytope.py  # 5 doctests failed
sage -t --long src/sage/geometry/triangulation/point_configuration.py  # 1 doctest failed
sage -t --long src/sage/geometry/polyhedron/base.py  # 4 doctests failed
----------------------------------------------------------------------
Total time for all tests: 30.8 seconds
    cpu time: 61.4 seconds
    cumulative wall time: 83.0 seconds

Change History (8)

comment:1 follow-up: Changed 3 years ago by vbraun

Those are all automorphism group related, presumably due the optional bliss?

comment:2 follow-up: Changed 3 years ago by chapoton

duplicate of #25426 ?

comment:3 in reply to: ↑ 2 Changed 3 years ago by slabbe

Replying to chapoton:

duplicate of #25426 ?

No. But with the branch at #25426, I get fewer failures:

----------------------------------------------------------------------
sage -t --long src/sage/geometry/fan_isomorphism.py  # 1 doctest failed
sage -t --long src/sage/geometry/polyhedron/ppl_lattice_polytope.py  # 3 doctests failed
sage -t --long src/sage/geometry/triangulation/point_configuration.py  # 1 doctest failed
sage -t --long src/sage/geometry/polyhedron/base.py  # 3 doctests failed
----------------------------------------------------------------------

comment:4 Changed 3 years ago by slabbe

Actually, it is a duplicate of #25399.

comment:5 in reply to: ↑ 1 Changed 3 years ago by slabbe

Replying to vbraun:

Those are all automorphism group related, presumably due the optional bliss?

Yes: Using --optional=bliss,cbc,ccache,cmake,dot2tex,gmpy2,mpir,python2,sage

comment:6 Changed 3 years ago by slabbe

  • Milestone changed from sage-8.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

I suggest to close this ticket as duplicate of #25399.

comment:7 Changed 3 years ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

comment:8 Changed 3 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.