Opened 3 years ago

Closed 3 years ago

#25437 closed PLEASE CHANGE (invalid)

TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

Reported by: Bruce Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: PLEASE CHANGE Keywords:
Cc: Merged in:
Authors: Bruce Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

How to Reproduce

While doing a GET operation on /ticket/25434, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'25434'}

User agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Interface Customization

Interface customization information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 587, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 266, in dispatch
    iterable=chrome.use_chunked_encoding)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1112, in render_template
    stream |= self._filter_stream(req, method, filename, stream, data)
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 133, in __or__
    return Stream(_ensure(function(self)), serializer=self.serializer)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1398, in inner
    data)
  File "/usr/local/lib/python2.7/dist-packages/sage_trac/ticket_box.py", line 102, in filter_stream
    filters.extend(self._get_branch_filters(req, ticket))
  File "/usr/local/lib/python2.7/dist-packages/sage_trac/ticket_box.py", line 169, in _get_branch_filters
    base=base_branch_commit)
  File "/usr/local/lib/python2.7/dist-packages/sage_trac/git_merger.py", line 250, in get_merge_url
    log_url = self.log_url(log_base, branch)
  File "/usr/local/lib/python2.7/dist-packages/sage_trac/common.py", line 157, in log_url
    'q': base+'..'+tip,
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

Change History (1)

comment:1 Changed 3 years ago by embray

  • Milestone changed from sage-8.3 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from new to closed

Closing this since issues with Trac shouldn't be reported here. I'll look into it.

Note: See TracTickets for help on using tickets.