Opened 4 years ago

Last modified 4 years ago

#25292 closed enhancement

Upgrade to Cython 0.29 — at Version 8

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-8.5
Component: packages: standard Keywords:
Cc: fbissey, embray, saraedum Merged in:
Authors: Jeroen Demeyer Reviewers:
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: u/jdemeyer/upgrade_to_cython_0_29 (Commits, GitHub, GitLab) Commit: 32756374dc60e6a34730ae05424a3467701b1e9b
Dependencies: #26396, #26402 Stopgaps:

Status badges

Description (last modified by jdemeyer)

There is no Cython 0.29 yet, but there is a release candidate

Tarball: https://github.com/cython/cython/archive/0.29rc2.tar.gz

Follow-up tickets:

  • #25288: Enable Cython caching again
  • #26403: Compile Sage with Cython language_level=3str

Change History (8)

comment:1 Changed 4 years ago by vdelecroix

  • Milestone changed from sage-8.3 to sage-8.4

update milestone 8.3 -> 8.4

comment:2 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 4 years ago by fbissey

  • Cc fbissey added

comment:4 Changed 4 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Dependencies set to #26396

comment:5 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:6 Changed 4 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_to_cython_0_29

comment:7 Changed 4 years ago by git

  • Commit set to 32756374dc60e6a34730ae05424a3467701b1e9b

Branch pushed to git repo; I updated commit sha1. New commits:

3275637Explicitly set Cython language level to current Python version

comment:8 Changed 4 years ago by jdemeyer

  • Dependencies changed from #26396 to #26396, #26402
  • Description modified (diff)
Note: See TracTickets for help on using tickets.