#25217 closed defect (fixed)

Fix test regression in banner()

Reported by: embray Owned by:
Priority: blocker Milestone: sage-8.2
Component: misc Keywords:
Cc: Merged in:
Authors: Erik Bray Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: f8c1038 (Commits) Commit: f8c1038d3bdfe501d6036f21347171778e80094b
Dependencies: Stopgaps:

Description

Fixes regression introduced in #25056 that assumes the tests are running without the SAGE_BANNER environment variable set to a non-default.

(We should have a better mechanism in general for setting sage.env to the default for tests that depend on it)

Change History (3)

comment:1 Changed 22 months ago by embray

  • Authors set to Erik Bray
  • Branch set to u/embray/misc/ticket-25217
  • Commit set to f8c1038d3bdfe501d6036f21347171778e80094b
  • Status changed from new to needs_review

New commits:

f8c1038Enforce the default value of SAGE_BANNER before running this test, since otherwise it might now pass

comment:2 Changed 22 months ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:3 Changed 22 months ago by vbraun

  • Branch changed from u/embray/misc/ticket-25217 to f8c1038d3bdfe501d6036f21347171778e80094b
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.