Opened 3 years ago

Closed 16 months ago

#25171 closed enhancement (invalid)

Experimental FLINT upgrade package tracking trunk

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: vdelecroix, dimpase Merged in:
Authors: Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: u/mkoeppe/experimental_flint_upgrade_package_tracking_trunk (Commits, GitHub, GitLab) Commit: 0c93e30756bd86b06673e732a3d2a6af08b92ed0
Dependencies: Stopgaps:

Status badges

Description (last modified by mkoeppe)

This ticket is for tracking whether Sage works with the development version of FLINT.

Upstream https://github.com/wbhart/flint2 has no tags.

wget https://github.com/mkoeppe/flint2/archive/2.5.2+trunk-2018-09-18-e12c83de3e100a113dbc030894d89f67dfe83cd4.tar.gz -O upstream/flint-2.5.2+trunk-2018-09-18-e12c83de3e100a113dbc030894d89f67dfe83cd4.tar.gz

Change History (13)

comment:1 Changed 3 years ago by mkoeppe

  • Description modified (diff)
  • Milestone changed from sage-8.2 to sage-8.4
  • Summary changed from Experimental FLINT upgrade package tracking master to Experimental FLINT upgrade package tracking trunk

comment:2 Changed 3 years ago by mkoeppe

  • Branch set to u/mkoeppe/experimental_flint_upgrade_package_tracking_trunk

comment:3 Changed 3 years ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to 13089b4c96b209bca2dc056d62db6bbdc3925363
  • Description modified (diff)
  • Status changed from new to needs_review

This is not ready for merging because there's no upstream release. Setting it to needs_review only so the patchbots run on it.


New commits:

8b4deccExperimental upgrade of FLINT to 2.5.2+trunk-2018-09-18-e12c83de3e100a113dbc030894d89f67dfe83cd4; remove patches
13089b4build/pkgs/flint/checksums.ini: Update for using github release tarball

comment:4 Changed 2 years ago by git

  • Commit changed from 13089b4c96b209bca2dc056d62db6bbdc3925363 to 46fcf67056a9c23746469b0e6c28752052ad57b5

Branch pushed to git repo; I updated commit sha1. New commits:

46fcf67Merge tag '8.8.beta3' into t/25171/experimental_flint_upgrade_package_tracking_trunk

comment:5 Changed 2 years ago by git

  • Commit changed from 46fcf67056a9c23746469b0e6c28752052ad57b5 to 76d7db13b9345db528715f6e0e251008b99cd7b0

Branch pushed to git repo; I updated commit sha1. New commits:

76d7db1Add patch

comment:6 Changed 2 years ago by git

  • Commit changed from 76d7db13b9345db528715f6e0e251008b99cd7b0 to 0c93e30756bd86b06673e732a3d2a6af08b92ed0

Branch pushed to git repo; I updated commit sha1. New commits:

0c93e30Add FLINT patch install_name_tool_destdir.patch

comment:7 Changed 2 years ago by mkoeppe

  • Milestone changed from sage-8.4 to sage-wishlist

comment:8 Changed 2 years ago by vdelecroix

  • Status changed from needs_review to needs_info

Hi Matthias,

I don't understand the ticket description. Normaliz works perfectly well with flint master.

Also, patchbot will never run this ticket since they are not able to download the tarball.

comment:9 Changed 2 years ago by mkoeppe

No worries, this ticket no longer needed with the current e-antic.

comment:10 Changed 2 years ago by mkoeppe

  • Description modified (diff)

comment:11 Changed 16 months ago by mkoeppe

  • Cc dimpase added
  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Status changed from needs_info to needs_review

Obsolete because of #29719 (upgrade to flint 2.6.0), should be closed

comment:12 Changed 16 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

comment:13 Changed 16 months ago by chapoton

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.