Opened 4 years ago

Closed 3 years ago

#25158 closed enhancement (invalid)

avoid cmake installation when possible

Reported by: vklein Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: cmake
Cc: fbissey, vdelecroix, slelievre Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #24919 Stopgaps:

Status badges

Description

If cmake is already installed (system wide) and is a dependencie of another sage package cmake sage package shouldn't be installed.

The desired behaviour is sort of similar to gcc, yasm or curl, except cmake is an optional package.

This ticket is following the ticket #25109 discussion.

Change History (7)

comment:1 Changed 4 years ago by vklein

  • Authors changed from Vicnent Klein to Vincent Klein

comment:2 Changed 4 years ago by vklein

  • Authors Vincent Klein deleted

comment:3 Changed 3 years ago by vdelecroix

  • Dependencies set to #24919

comment:4 Changed 3 years ago by slelievre

See also #27487.

comment:5 Changed 3 years ago by slelievre

  • Cc slelievre added
  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Set to positive review if you agree this is a duplicate of #27487.

comment:6 Changed 3 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

comment:7 Changed 3 years ago by vdelecroix

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.