#25141 closed enhancement (fixed)

Homomorphisms around FQSym, WQSym

Reported by: darij Owned by:
Priority: major Milestone: sage-8.3
Component: combinatorics Keywords: IMA coding sprint, CHAs, ordered set partitions, WQSym
Cc: tscrim, sage-combinat, zabrocki, alauve, saliola, amypang Merged in:
Authors: Darij Grinberg Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 6735ebb (Commits) Commit: 6735ebb1242f7583e83a045fb4c4abfe40d479db
Dependencies: #25133, #25131, #25155 Stopgaps:

Description (last modified by gh-darijgr)

We implement the following canonical homomorphisms of combinatorial Hopf algerbras: NCSF -> FQSym -> WQSym and NCSym -> WQSym.

Change History (35)

comment:1 Changed 18 months ago by darij

  • Branch set to public/combinat/wqsym2
  • Commit set to 5dad9df6789fa9b4c0526a0801b6629a23e3478c

Last 10 new commits:

f4ad056Fixing documentation to Cone basis.
60662bereview M and X bases of WQSym
3b67a89customize hash on OrderedSetPartition (Travis)
24e9b0fcorrect degree_on_basis
8a36664documentation fixes
b4a3af9implement WQSym -> QSym projection
fc6b2aefix to_quasisymmetric_function
acf384bG-basis and bugfixes
361b4dfMerge branch 'public/combinat/fqsym' of trac.sagemath.org:sage into wqsym_real
5dad9dfimplement the inclusion NSym -> FQSym

comment:2 Changed 18 months ago by git

  • Commit changed from 5dad9df6789fa9b4c0526a0801b6629a23e3478c to c833ba61d20d747b26426c39dbeb5db7c3035f28

Branch pushed to git repo; I updated commit sha1. New commits:

c833ba6implement FiniteWord.to_ordered_set_partition()

comment:3 Changed 18 months ago by git

  • Commit changed from c833ba61d20d747b26426c39dbeb5db7c3035f28 to 5dc2bfe2949841dac4ddb594a208d61bebedf363

Branch pushed to git repo; I updated commit sha1. New commits:

474d8f9Having to_ncsym() and to_fqsym() implemented generically for elements only.
5dc2bfeMerge branch 'public/combinat/wqsym2' of git://trac.sagemath.org/sage into public/combinat/wqsym2

comment:4 Changed 18 months ago by darij

The output weirdness in that last commit has nothing to do with set partitions btw:

sage: Set([2,3,5,8])
{8, 2, 3, 5}
sage: frozenset([2,3,5,8])
frozenset({2, 3, 5, 8})

comment:5 Changed 18 months ago by git

  • Commit changed from 5dc2bfe2949841dac4ddb594a208d61bebedf363 to 85634b2924d43875c92377d3d17af19bf1648415

Branch pushed to git repo; I updated commit sha1. New commits:

85634b2outsource to_ordered_set_partition

comment:6 Changed 18 months ago by git

  • Commit changed from 85634b2924d43875c92377d3d17af19bf1648415 to 72bcd46971d22833d27a73988a92425f63f133c6

Branch pushed to git repo; I updated commit sha1. New commits:

72bcd46implement the inclusion FQSym -> WQSym

comment:7 Changed 18 months ago by git

  • Commit changed from 72bcd46971d22833d27a73988a92425f63f133c6 to 32ccd587b4394c90e415fae05146e446d9525ad6

Branch pushed to git repo; I updated commit sha1. New commits:

32ccd58polish Travis's edits

comment:8 Changed 18 months ago by git

  • Commit changed from 32ccd587b4394c90e415fae05146e446d9525ad6 to a5512ed4b43cf58de8340f67c0eca637d4336f03

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

a5512edpolish Travis's edits

comment:9 Changed 18 months ago by git

  • Commit changed from a5512ed4b43cf58de8340f67c0eca637d4336f03 to 7394bf72547be83dc1d80f1012ee239879d12383

Branch pushed to git repo; I updated commit sha1. New commits:

7394bf7Added deprecations to Bases.ParentMethod.to_ncsym(_on_basis).

comment:10 Changed 18 months ago by git

  • Commit changed from 7394bf72547be83dc1d80f1012ee239879d12383 to 235f69b51a2c77c5dbad23ffa0bdbf6773f9d05e

Branch pushed to git repo; I updated commit sha1. New commits:

235f69bimplement the inclusion NCSym -> WQSym

comment:11 Changed 18 months ago by darij

  • Status changed from new to needs_review

comment:12 Changed 18 months ago by git

  • Commit changed from 235f69b51a2c77c5dbad23ffa0bdbf6773f9d05e to 1253d45d29960a3cfa11242b714c7c0932999f7a

Branch pushed to git repo; I updated commit sha1. New commits:

1253d45Revert separation of to_ordered_set_partition in finite words.

comment:13 Changed 18 months ago by tscrim

  • Branch changed from public/combinat/wqsym2 to public/combinat/wqsym_morphisms-25141
  • Commit changed from 1253d45d29960a3cfa11242b714c7c0932999f7a to 235f69b51a2c77c5dbad23ffa0bdbf6773f9d05e
  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

LGTM (I reverted my reviewer commit on the resulting branch).

comment:14 Changed 18 months ago by darij

Thank you Travis!

comment:15 Changed 18 months ago by git

  • Commit changed from 235f69b51a2c77c5dbad23ffa0bdbf6773f9d05e to faad4617d3a0cd44f489e0183ad0ce32f0471036
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

faad461fix documentation

comment:16 Changed 18 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

comment:17 Changed 18 months ago by git

  • Commit changed from faad4617d3a0cd44f489e0183ad0ce32f0471036 to 70ccf5f02fd4cb8dc38e40787cd23b5d7a495698
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

f75e10dif w1 is a word, return a word, else a list
3f8f272added doc test, minor change for test of Composition, correct import
06fd19dMerge branch 'public/25018/bug_in_shuffle' of git://trac.sagemath.org/sage into public/combinat/extend_shuffle_product-15597
4252484Merge branch 'public/combinat/extend_shuffle_product-15597' of git://trac.sagemath.org/sage into public/combinat/implement_wqsym-25133
82240b2Fixing some details and making Symmetric capitalized in the name.
eb52ae3Merge branch 'public/combinat/implement_wqsym-25133' of trac.sagemath.org:sage into homs
2d6d158Merge branch 'public/combinat/wqsym_morphisms-25141' of trac.sagemath.org:sage into homs
70ccf5fchanges necessitated by renaming in #25133

comment:18 Changed 18 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

comment:19 Changed 18 months ago by git

  • Commit changed from 70ccf5f02fd4cb8dc38e40787cd23b5d7a495698 to eba7fca8d32b9742421e85533b2d38ca597df248
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

db3f885Initial addition of Franco's FSym code.
51f31adMerge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141
eba7fcaFixing issue with capitalization.

comment:20 Changed 18 months ago by git

  • Commit changed from eba7fca8d32b9742421e85533b2d38ca597df248 to 2dfbcac4f06908682273ccb54a468ec06eff19ef

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

2dfbcacFixing issue with capitalization.

comment:21 Changed 18 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

comment:22 Changed 18 months ago by git

  • Commit changed from 2dfbcac4f06908682273ccb54a468ec06eff19ef to dff5f15b50f9cb4061a6b9d1bdc8fc60868f6846
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

dff5f15improvements to to_wqsym methods

comment:23 Changed 18 months ago by git

  • Commit changed from dff5f15b50f9cb4061a6b9d1bdc8fc60868f6846 to 47ab2ac7eeaae9f4bf58c30b993072b456bf86a8

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

47ab2acimprovements to to_wqsym methods

comment:24 Changed 18 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

Travis has confirmed positive review for the branch as it now stands. Sorry for the back and forth!

comment:25 Changed 17 months ago by git

  • Commit changed from 47ab2ac7eeaae9f4bf58c30b993072b456bf86a8 to 1dfb703496ffcaaeff926a3782e4993d4d181440
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

05fbde8Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into 25141
1dfb703trivial changes

comment:26 Changed 17 months ago by gh-darijgr

  • Description modified (diff)
  • Status changed from needs_review to positive_review

Added a little commit that corrects some doc and replaces sorted(uniq(...)) by the slightly faster sorted(set(...)). Hope that the patchbot is no longer confused.

comment:27 Changed 17 months ago by git

  • Commit changed from 1dfb703496ffcaaeff926a3782e4993d4d181440 to 0efedd0edddc72f1e3bd90a9b95f29055fdff7c4
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

c8c6906Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141
9d90234Initial additional of global options to WQSym
fd61441Added two global options for display of elements of WordQuasiSymmetricFunctions.
c828b0eSome reviewer changes.
ba70317A few more reviewer changes.
6e50492updated doc string for intended usage vis.a.vis packed words
27b9a98doctest and Travis' check
0efedd0Merge branch 'public/combinat/wqsym_options-25155' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141

comment:28 Changed 17 months ago by tscrim

  • Dependencies changed from #25133, #25131 to #25133, #25131, #25155
  • Status changed from needs_review to positive_review

Essentially a trivial rebase over #25155.

comment:29 Changed 17 months ago by git

  • Commit changed from 0efedd0edddc72f1e3bd90a9b95f29055fdff7c4 to 728ff81d5f0959bcab23b6ea4a1ea2e1bf1a0f13
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

bc276ddMerge branch 'public/combinat/implement_wqsym-25133' of git://trac.sagemath.org/sage into public/combinat/implement_wqsym-25133
728ff81Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141

comment:30 Changed 17 months ago by tscrim

  • Status changed from needs_review to positive_review

Trivial rebase.

comment:31 Changed 16 months ago by gh-darijgr

  • Milestone changed from sage-8.2 to sage-8.3

What are the bots fussing about?

comment:32 Changed 16 months ago by git

  • Commit changed from 728ff81d5f0959bcab23b6ea4a1ea2e1bf1a0f13 to 186d782f99ed4d89621da92d00f3db68dd1849f7
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

186d782Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into 25141

comment:33 Changed 16 months ago by git

  • Commit changed from 186d782f99ed4d89621da92d00f3db68dd1849f7 to 6735ebb1242f7583e83a045fb4c4abfe40d479db

Branch pushed to git repo; I updated commit sha1. New commits:

6735ebbfix doc of from_finite_word

comment:34 Changed 16 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

That was a trivial doc fix. Can the patchbots now do their job at last?

comment:35 Changed 16 months ago by vbraun

  • Branch changed from public/combinat/wqsym_morphisms-25141 to 6735ebb1242f7583e83a045fb4c4abfe40d479db
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.