#25137 closed defect (fixed)

Temporarily skip the test that causes #24986

Reported by: embray Owned by:
Priority: blocker Milestone: sage-8.2
Component: cython Keywords:
Cc: jdemeyer, vbraun Merged in:
Authors: Erik Bray Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: 04e3f29 (Commits) Commit: 04e3f29ae65b77b0dbdecdc7c74851b670642800
Dependencies: Stopgaps:

Description

It would be nice if we could temporarily disable the test that causes #24986 as known-problematic, at least until a fix is in (which hopefully will be soon, but probably not soon-enough).

Although I've only reproduced this issue on Cygwin, the test is theoretically a problem on any platform, though we know it passes in the general case (in fact it passes on Cygwin too--just causing minor corruption in the process). The issue it's testing is also more to do with Cysignals than with Sage itself.

Therefor I propose that we skip it for now--that way I'll have all tests passing on Cygwin for Sage 8.2 (at least with #25077 included as well).

If this is acceptable I'll add a note to #24986 reminding to re-enable the test once the issue is fixed.

Change History (4)

comment:1 Changed 18 months ago by embray

  • Status changed from new to needs_review

comment:2 Changed 17 months ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:3 Changed 17 months ago by embray

Thanks!

comment:4 Changed 17 months ago by vbraun

  • Branch changed from u/embray/doctests/skip-24986 to 04e3f29ae65b77b0dbdecdc7c74851b670642800
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.