Opened 17 months ago

Closed 15 months ago

Last modified 15 months ago

#25136 closed enhancement (fixed)

Add monomial basis to FQSym

Reported by: tscrim Owned by:
Priority: major Milestone: sage-8.3
Component: combinatorics Keywords: IMA coding sprint, CHAs, permutations
Cc: sage-combinat, darij, alauve, zabrocki, saliola, amypang Merged in:
Authors: Darij Grinberg Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 8dc0c5c (Commits) Commit:
Dependencies: #25131, #25141 Stopgaps:

Description

The monomial basis of Aguiar and Sottile (see 1.3 in ​http://www.math.tamu.edu/~sottile/research/pdf/SSym.pdf ; the formula (1.13) is most important, and triangularity should do the rest, if we make sure that the order is right).

Change History (18)

comment:1 Changed 17 months ago by darij

  • Authors set to Darij Grinberg
  • Branch set to public/combinat/fqsym2
  • Commit set to e79d2d398a032086f542d651f561d0f18c51a21b

New commits:

acf384bG-basis and bugfixes
e79d2d3Merge branch 'public/combinat/fqsym' of trac.sagemath.org:sage into fq2

comment:2 Changed 17 months ago by git

  • Commit changed from e79d2d398a032086f542d651f561d0f18c51a21b to 2acec0011d92c0a65e689e6dde250230a53cf26b

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

5dc2bfeMerge branch 'public/combinat/wqsym2' of git://trac.sagemath.org/sage into public/combinat/wqsym2
85634b2outsource to_ordered_set_partition
72bcd46implement the inclusion FQSym -> WQSym
a5512edpolish Travis's edits
7394bf7Added deprecations to Bases.ParentMethod.to_ncsym(_on_basis).
235f69bimplement the inclusion NCSym -> WQSym
58d17adMerge branch 'public/combinat/wqsym_morphisms-25141' of trac.sagemath.org:sage into fq2
7dd85ffimplement the M basis of FQSym
faad461fix documentation
2acec00Merge branch 'WQS' into fq2

comment:3 Changed 17 months ago by git

  • Commit changed from 2acec0011d92c0a65e689e6dde250230a53cf26b to 78a4253e73accdc58060e7f20ac77a1027ce2db1

Branch pushed to git repo; I updated commit sha1. New commits:

78a4253overload coproduct on M-basis for speed

comment:4 Changed 17 months ago by gh-darijgr

  • Dependencies changed from #25131 to #25131, #25141
  • Status changed from new to needs_review

There it is. (I'm Darij, logging in through github.)

comment:5 Changed 17 months ago by git

  • Commit changed from 78a4253e73accdc58060e7f20ac77a1027ce2db1 to ef1f3b78ff16516ee9b25f8c767ca9bc34ca6c39

Branch pushed to git repo; I updated commit sha1. New commits:

ef1f3b7link FQSym doc

comment:7 Changed 17 months ago by git

  • Commit changed from ef1f3b78ff16516ee9b25f8c767ca9bc34ca6c39 to 98fca9c1edca09366037b5b900496f4cde39bd89

Branch pushed to git repo; I updated commit sha1. New commits:

f75e10dif w1 is a word, return a word, else a list
3f8f272added doc test, minor change for test of Composition, correct import
06fd19dMerge branch 'public/25018/bug_in_shuffle' of git://trac.sagemath.org/sage into public/combinat/extend_shuffle_product-15597
4252484Merge branch 'public/combinat/extend_shuffle_product-15597' of git://trac.sagemath.org/sage into public/combinat/implement_wqsym-25133
82240b2Fixing some details and making Symmetric capitalized in the name.
eb52ae3Merge branch 'public/combinat/implement_wqsym-25133' of trac.sagemath.org:sage into homs
2d6d158Merge branch 'public/combinat/wqsym_morphisms-25141' of trac.sagemath.org:sage into homs
70ccf5fchanges necessitated by renaming in #25133
98fca9cMerge branch 'public/combinat/fqsym2' of trac.sagemath.org:sage into homs

comment:8 Changed 17 months ago by git

  • Commit changed from 98fca9c1edca09366037b5b900496f4cde39bd89 to 416a8c086d21c467e0510564c99ae64a415f2e58

Branch pushed to git repo; I updated commit sha1. New commits:

416a8c0more corrections due to recent merge

comment:9 Changed 17 months ago by git

  • Commit changed from 416a8c086d21c467e0510564c99ae64a415f2e58 to 6e4066617f6365c415ef25281b9fdf0026572544

Branch pushed to git repo; I updated commit sha1. New commits:

2dfbcacFixing issue with capitalization.
4f2ddfeMerge branch 'public/combinat/fqsym2' of git://trac.sagemath.org/sage into public/combinat/fqsym2
beeea6aAbstracting methods to DRY.
6e40666Calling the M basis the monomial basis.

comment:10 Changed 17 months ago by gh-darijgr

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:11 Changed 16 months ago by git

  • Commit changed from 6e4066617f6365c415ef25281b9fdf0026572544 to 8dc0c5c9f5dea1f78a6cdac21db48b787ceaa8d0
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. Last 10 new commits:

c8c6906Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141
9d90234Initial additional of global options to WQSym
fd61441Added two global options for display of elements of WordQuasiSymmetricFunctions.
c828b0eSome reviewer changes.
ba70317A few more reviewer changes.
6e50492updated doc string for intended usage vis.a.vis packed words
27b9a98doctest and Travis' check
0efedd0Merge branch 'public/combinat/wqsym_options-25155' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141
728ff81Merge branch 'public/combinat/wqsym_morphisms-25141' of git://trac.sagemath.org/sage into public/combinat/wqsym_morphisms-25141
8dc0c5cMerge branch 'public/combinat/fqsym2' of git://trac.sagemath.org/sage into 25136

comment:12 Changed 16 months ago by gh-darijgr

  • Status changed from needs_review to positive_review

Trivial rebase over one of the dependencies.

comment:13 Changed 16 months ago by gh-darijgr

  • Milestone changed from sage-8.2 to sage-8.3

wake up patchbots

comment:14 Changed 16 months ago by gh-darijgr

File "src/sage/combinat/ncsym/bases.py", line 640, in sage.combinat.ncsym.bases.NCSymBases.ElementMethods.to_wqsym
Failed example:
    (4*p[[1,3],[2]]-p[[1]]).to_wqsym()
Expected:
    4*M[{1, 2, 3}] + 4*M[{2}, {1, 3}] + 4*M[{1, 3}, {2}] - M[{1}]
Got:
    4*M[{2}, {1, 3}] - M[{1}] + 4*M[{1, 2, 3}] + 4*M[{1, 3}, {2}]

Can't reproduce this one. But it's from a few versions ago, so maybe it's fixed now.

comment:15 Changed 16 months ago by gh-darijgr

The last patchbot is happy now, so I think this is ready to go.

comment:16 Changed 15 months ago by vbraun

  • Branch changed from public/combinat/fqsym2 to 8dc0c5c9f5dea1f78a6cdac21db48b787ceaa8d0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:17 Changed 15 months ago by chapoton

  • Commit 8dc0c5c9f5dea1f78a6cdac21db48b787ceaa8d0 deleted

FQSYM doctests now take way too long..

comment:18 Changed 15 months ago by gh-darijgr

Are they still taking too long if you pull #25326 as well? One of the things I did in #25326 was optimizing FQSym, particularly the M basis.

(NB: I don't know how long doctests *should* take on Cygwin, so I have no way to tell if I'm doing things right.)

Note: See TracTickets for help on using tickets.