Opened 4 years ago

Closed 4 years ago

#25093 closed defect (fixed)

Use year of release for copyright

Reported by: saraedum Owned by:
Priority: trivial Milestone: sage-8.3
Component: documentation Keywords: debian, doc
Cc: infinity0 Merged in:
Authors: Julian Rüth Reviewers: Ximin Luo
Report Upstream: N/A Work issues:
Branch: a69f4b2 (Commits, GitHub, GitLab) Commit: a69f4b265866c437bf72a995be25421e1e82b607
Dependencies: Stopgaps:

Status badges

Description (last modified by saraedum)

not the year of the build.

Currently, Debian patches Sage to get a stable copyright information:

Description: Generate documentation reproducibly
 TODO: make this use SOURCE_DATE_EPOCH instead which is set automatically by debhelper
 https://wiki.debian.org/ReproducibleBuilds/TimestampsProposal#Python
Author: Ximin Luo <infinity0@debian.org>
Forwarded: TODO
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/sage/src/doc/common/conf.py
+++ b/sage/src/doc/common/conf.py
@@ -61,7 +61,7 @@
 
 # General information about the project.
 project = u""
-copyright = u"2005--{}, The Sage Development Team".format(date.today().year)
+copyright = u"2005--2016, The Sage Development Team"
 
 # The version info for the project you're documenting, acts as replacement for
 # |version| and |release|, also used in various other places throughout the

Since version.date already contains the date of the release, we should just use that instead.

Change History (13)

comment:1 Changed 4 years ago by saraedum

  • Branch set to u/saraedum/sage-doc-year

comment:2 Changed 4 years ago by saraedum

  • Commit set to a69f4b265866c437bf72a995be25421e1e82b607
  • Description modified (diff)

New commits:

a69f4b2Use year of release in copyright

comment:3 Changed 4 years ago by saraedum

  • Cc infinity0 added

comment:4 Changed 4 years ago by saraedum

  • Description modified (diff)

comment:5 follow-up: Changed 4 years ago by infinity0

Looks good to me, thanks for doing this and all the other tickets! I am not a Sage dev though so not sure I can officially "pass" the review. However, I will for sure add it to the Debian package when I next touch that.

comment:6 Changed 4 years ago by saraedum

http://doc.sagemath.org/html/en/developer/reviewer_checklist.html says "Anybody (e.g. you) can do this job for somebody else’s ticket."

But I understand if you want to wait for a more established dev to take a look at this.

Btw., it would be great if you could add your real name to trac.sagemath.org.

comment:7 in reply to: ↑ 5 Changed 4 years ago by jdemeyer

Replying to infinity0:

I am not a Sage dev though so not sure I can officially "pass" the review.

You can. But the author should set the ticket to needs_review first.

comment:8 Changed 4 years ago by saraedum

  • Status changed from new to needs_review

comment:9 Changed 4 years ago by infinity0

  • Status changed from needs_review to positive_review

comment:10 Changed 4 years ago by chapoton

missing reviewer's name

comment:11 Changed 4 years ago by saraedum

  • Reviewers set to Ximin Luo

comment:12 Changed 4 years ago by davidloeffler

  • Milestone changed from sage-8.2 to sage-8.3

comment:13 Changed 4 years ago by vbraun

  • Branch changed from u/saraedum/sage-doc-year to a69f4b265866c437bf72a995be25421e1e82b607
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.