Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#25031 closed defect (fixed)

Invalid dependencies when building with gcc

Reported by: Volker Braun Owned by:
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Jeroen Demeyer Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

make[1]: *** No rule to make target `/home/buildbot/slave/sage_git/build/local/bin/gccmpir', needed by `/home/buildbot/slave/sage_git/build/local/var/lib/sage/installed/arb-2.12.0.p0'.  Stop.

From build/make/Makefile:

deps_arb =  $(SAGE_LOCAL)/bin/gcc$(MP_LIBRARY) mpfr flint

Change History (5)

comment:1 Changed 5 years ago by Ralf Stephan

This line reads "deps_arb = $(MP_LIBRARY) mpfr flint" in my clang installation.

comment:2 Changed 5 years ago by Volker Braun

Because you have a working gcc so the optional built-in gcc is not compiled...

comment:3 Changed 5 years ago by Erik Bray

Milestone: sage-8.2sage-duplicate/invalid/wontfix
Status: newneeds_review

This was already fixed by #24961

comment:4 Changed 5 years ago by Jeroen Demeyer

Resolution: duplicate
Status: needs_reviewclosed

comment:5 Changed 5 years ago by Volker Braun

Resolution: duplicatefixed
Note: See TracTickets for help on using tickets.