Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#24953 closed defect (duplicate)

Sage does not build on vfat filesystems

Reported by: jdemeyer Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: embray Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This check in build/bin/sage-spkg should really depend on the filesystem and not on the OS:

                msg="$script should not be marked executable in the build/pkgs directory"
                if [ "$UNAME" = "CYGWIN" ]; then
                    # On Cygwin we can't necessarily rely on file permissions
                    # being sane, so just issue a warning; on other platforms
                    # this should be enforced as an error
                    echo >&2 "WARNING: $msg"
                else
                    error_msg "$msg"
                    exit 1
                fi

Change History (6)

comment:1 Changed 3 years ago by saraedum

  • Priority changed from critical to minor

I took the liberty to downgrade this. I don't see why this would be critical. Feel free to set it back.

Of course this check is wrong in theory, but at the moment I feel it's good enough. We could change the comment by replacing "Cygwin" with "vfat & friends" but it's not worth to figure out the file system from my point of view.

comment:2 follow-up: Changed 3 years ago by embray

I think also lots of other things will go wrong if you try to build on a VFAT filesystem.

comment:3 Changed 3 years ago by saraedum

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

If jdemeyer agrees, we should close this.

comment:4 in reply to: ↑ 2 Changed 3 years ago by jdemeyer

Replying to embray:

I think also lots of other things will go wrong if you try to build on a VFAT filesystem.

Like symlinks I guess?

comment:5 Changed 3 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from needs_review to closed

Duplicate of #25207

comment:6 Changed 3 years ago by embray

I guess really #25207 could be considered a duplicate of this ticket, albeit a bit broader in scope.

I'm still not sure about FAT if you can't have symlinks though...

Note: See TracTickets for help on using tickets.