Opened 3 years ago

Closed 3 years ago

#24906 closed defect (duplicate)

"non-identical C method 'add_variable' not redeclared" warings building InteractiveLPBackend and GurobiBackend

Reported by: dimpase Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear programming Keywords:
Cc: mkoeppe Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

[sagelib-8.2.beta7] warning: sage/numerical/backends/gurobi_backend.pyx:90:10: Compatible but non-identical C method 'add_variable' not redeclared in definition part of extension type 'GurobiBackend'.  This may cause incorrect vtables to be generated.
[sagelib-8.2.beta7] warning: sage/numerical/backends/generic_backend.pxd:13:26: Previous declaration is here
[sagelib-8.2.beta7] [329/489] Cythonizing sage/numerical/backends/interactivelp_backend.pyx
[sagelib-8.2.beta7] warning: sage/numerical/backends/interactivelp_backend.pyx:179:10: Compatible but non-identical C method 'add_variable' not redeclared in definition part of extension type 'InteractiveLPBackend'.  This may cause incorrect vtables to be generated.
[sagelib-8.2.beta7] warning: sage/numerical/backends/generic_backend.pxd:13:26: Previous declaration is here

Change History (5)

comment:1 Changed 3 years ago by dimpase

not sure whether these can be ignored.

comment:2 Changed 3 years ago by jdemeyer

This is more or less a duplicate of #20324. If you want, we could fix the Cython issue without fixing add_variable more generally. But #20324 has bigger plans for fixing add_variable which should also fix the Cython warnings.

comment:3 Changed 3 years ago by jdemeyer

Do you plan to fix this? If not, we might as well let it be and hope that somebody will address it in #20324.

comment:4 Changed 3 years ago by gh-dimpase

  • Milestone changed from sage-8.2 to sage-wishlist

my hands are full a.t.m.

comment:5 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.