Opened 5 years ago

Closed 5 years ago

#24902 closed defect (wontfix)

optional package deformation fails to build

Reported by: Vincent Delecroix Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: Jean-Pierre Flori Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Vincent Delecroix)

On archlinux

/usr/bin/ld: -r and -pie may not be used together

See the more complete log deformation-d05941b.log.

Upstream report: https://github.com/jpflori/pydeformation/issues/5

A patch is provided in #24575.

Attachments (1)

deformation-d05941b.log (8.0 KB) - added by Vincent Delecroix 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by Vincent Delecroix

Attachment: deformation-d05941b.log added

comment:1 Changed 5 years ago by Vincent Delecroix

Description: modified (diff)

comment:2 Changed 5 years ago by François Bissey

Flint had that issue some time ago. This is caused by the hardening of the toolchain. Look at what has been done for flint here https://github.com/sagemath/sage/blob/master/build/pkgs/flint/patches/flint-pie-hardening-conflict.patch. Basically you give -r directly to the compiler but don't pass it directly to the linker as you would with -Wl,-r.

comment:3 Changed 5 years ago by Vincent Delecroix

Cc: Jean-Pierre Flori added

comment:4 Changed 5 years ago by François Bissey

The culprit is this line

Makefile.subdirs:       $(QUIET_CC) $(CC) $(ABI_FLAG) -Wl,-r $^ -o $@ -nostdlib

Change -Wl,-r to plain -r should get you in business. Can someone also please update SPKG.txt with upstream location? Where did you get that tarball from? Has it been processed before being put on the mirror?

comment:5 Changed 5 years ago by Vincent Delecroix

A patch is provided in #24575, should I move it here?

Last edited 5 years ago by Vincent Delecroix (previous) (diff)

comment:6 in reply to:  5 Changed 5 years ago by Vincent Delecroix

Replying to vdelecroix:

A patch is provided in #24575, should I move it here?

comment:7 Changed 5 years ago by François Bissey

No need we can just mark this ticket as a "duplicate" of #24575.

comment:8 Changed 5 years ago by Vincent Delecroix

Description: modified (diff)
Milestone: sage-8.2sage-duplicate/invalid/wontfix
Status: newneeds_review

comment:9 Changed 5 years ago by Vincent Delecroix

Description: modified (diff)

comment:10 Changed 5 years ago by Frédéric Chapoton

Status: needs_reviewpositive_review

comment:11 Changed 5 years ago by Frédéric Chapoton

Priority: blockercritical

comment:12 Changed 5 years ago by Vincent Delecroix

Resolution: wontfix
Status: positive_reviewclosed

closing positively reviewed duplicates

Note: See TracTickets for help on using tickets.