Opened 5 years ago

Closed 5 years ago

#24867 closed defect (fixed)

The check for broken GCC should use src/bin/sage-env

Reported by: Jeroen Demeyer Owned by:
Priority: blocker Milestone: sage-8.2
Component: build: configure Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 3d62226 (Commits, GitHub, GitLab) Commit: 3d622262d0f6a4344c4d9b3faeb0c52419929934
Dependencies: Stopgaps:

Status badges

Description

The problem is that $SAGE_LOCAL/bin/sage-env is created as part of the build process. There is no guarantee that it exists after building GCC.

Change History (4)

comment:1 Changed 5 years ago by Jeroen Demeyer

Branch: u/jdemeyer/the_check_for_broken_gcc_should_use_src_bin_sage_env

comment:2 Changed 5 years ago by Jeroen Demeyer

Commit: 3d622262d0f6a4344c4d9b3faeb0c52419929934
Status: newneeds_review

New commits:

3d62226The check for broken GCC should use src/bin/sage-env

comment:3 Changed 5 years ago by Matthias Köppe

Reviewers: Matthias Koeppe
Status: needs_reviewpositive_review

comment:4 Changed 5 years ago by Volker Braun

Branch: u/jdemeyer/the_check_for_broken_gcc_should_use_src_bin_sage_env3d622262d0f6a4344c4d9b3faeb0c52419929934
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.