Opened 5 years ago

Closed 4 years ago

#24768 closed defect (invalid)

Powers of symbolic sums inconsistence

Reported by: Ralf Stephan Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers: Ralf Stephan
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: (-3*x-3)^2
9*(x + 1)^2

but

sage: (-I*x-I)^2
(-I*x - I)^2
sage: (4*x + 12)^(3/2)
(4*x + 12)^(3/2)

Expected would be -(x + 1)^2 and 8*(x + 3)^(3/2).

The power::eval code in Pynac is being cleaned up atm.

Change History (5)

comment:1 Changed 5 years ago by Ralf Stephan

Dependencies: pynac-0.7.17#24838

See also #25252.

comment:2 Changed 4 years ago by Ralf Stephan

Milestone: sage-8.2sage-duplicate/invalid/wontfix
Status: newneeds_review

Duplicate of #25639.

comment:3 Changed 4 years ago by Ralf Stephan

Status: needs_reviewpositive_review

comment:4 Changed 4 years ago by Karl-Dieter Crisman

Dependencies: #24838
Reviewers: Ralf Stephan

comment:5 Changed 4 years ago by Erik Bray

Resolution: invalid
Status: positive_reviewclosed

Presuming these are all correctly reviewed as either duplicate, invalid, or wontfix.

Note: See TracTickets for help on using tickets.