Opened 4 years ago

Last modified 3 years ago

#24575 needs_work defect

conflicts with gc — at Version 1

Reported by: vdelecroix Owned by:
Priority: critical Milestone: sage-8.2
Component: packages: standard Keywords:
Cc: embray, vbraun, charpent, defeo, jpflori Merged in:
Authors: Reviewers:
Report Upstream: Reported upstream. No feedback yet. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by vdelecroix)

Sage has a standard package gc which is also available for most operating system. The library creates conflicts with programs that are prerequisite to build Sage such as make.

For example, building Sage 8.2.beta3 on archlinux one gets

make: symbol lookup error: /usr/lib/libguile-2.2.so.1: undefined symbol: 
GC_move_disappearing_link

After deactivating the gc packages, the compilation went fine on this machine.

See also this report on sage-devel.

Change History (1)

comment:1 Changed 4 years ago by vdelecroix

  • Description modified (diff)
Note: See TracTickets for help on using tickets.