Opened 3 years ago

Closed 3 years ago

#24555 closed enhancement (duplicate)

ComplexNumber function is wrong

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

RealNumber in Sage is the class for floating-point real numbers. ComplexNumber is a function that aims to do the same for complex numbers but its implementation is very wrong.

sage: a = CC('1.233123145515341')
sage: b = ComplexNumber(a.real(), a.imag())
1.233123145515340
sage: ComplexNumber(a.real(), a.imag()) == b
False

We should either remove this function or improve it.

Change History (1)

comment:1 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13110

Note: See TracTickets for help on using tickets.