Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#24442 closed defect (duplicate)

coxeter3 unusable

Reported by: mantepse Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: Merged in:
Authors: Martin Rubey Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

after

sage -i coxeter3

(which reports success) I have

sage: from sage.libs.coxeter3.coxeter_group import CoxeterGroup
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-003c2198e7fe> in <module>()
----> 1 from sage.libs.coxeter3.coxeter_group import CoxeterGroup

/home/martin/sage-develop/local/lib/python2.7/site-packages/sage/libs/coxeter3/coxeter_group.py in <module>()
     11 from six import iteritems
     12 
---> 13 from sage.libs.coxeter3.coxeter import get_CoxGroup, CoxGroupElement
     14 from sage.misc.cachefunc import cached_method
     15 

ImportError: No module named coxeter

Change History (6)

comment:1 follow-up: Changed 3 years ago by mantepse

The error goes away if I do a make afterwards...

comment:2 follow-up: Changed 3 years ago by mantepse

However, now

sage: W = CoxeterGroup(['B', 3], implementation='coxeter3') # optional - coxeter3                                                                     
---------------------------------------------------------------------------
TypeError                                 Traceback (most recent call last)
<ipython-input-22-0569f607c268> in <module>()
----> 1 W = CoxeterGroup(['B', Integer(3)], implementation='coxeter3') # optional - coxeter3                                                          

/home/martin/sage-develop/src/sage/misc/classcall_metaclass.pyx in sage.misc.classcall_metaclass.ClasscallMetaclass.__call__ (build/cythonized/sage/m\
isc/classcall_metaclass.c:1589)()
    328         """                                                                                                                                   
    329         if cls.classcall is not None:
--> 330             return cls.classcall(cls, *args, **kwds)
    331         else:
    332             # Fast version of type.__call__(cls, *args, **kwds)                                                                               

/home/martin/sage-develop/local/lib/python2.7/site-packages/sage/libs/coxeter3/coxeter_group.pyc in __classcall__(cls, cartan_type, *args, **options)
     37         from sage.combinat.all import CartanType
     38         ct = CartanType(cartan_type)
---> 39         return super(CoxeterGroup, cls).__classcall__(cls, ct, *args, **options)
     40
     41     def __init__(self, cartan_type):

/home/martin/sage-develop/src/sage/misc/cachefunc.pyx in sage.misc.cachefunc.CachedFunction.__call__ (build/cythonized/sage/misc/cachefunc.c:6245)()
   1057                 return self.cache[k]
   1058         except KeyError:
-> 1059             w = self.f(*args, **kwds)
   1060             self.cache[k] = w
   1061             return w

/home/martin/sage-develop/local/lib/python2.7/site-packages/sage/structure/unique_representation.pyc in __classcall__(cls, *args, **options)
   1019             True
   1020         """                                                                                                                                   
-> 1021         instance = typecall(cls, *args, **options)
   1022         assert isinstance( instance, cls )
   1023         if instance.__class__.__reduce__ == CachedRepresentation.__reduce__:

/home/martin/sage-develop/src/sage/misc/classcall_metaclass.pyx in sage.misc.classcall_metaclass.typecall (build/cythonized/sage/misc/classcall_metac\
lass.c:2039)()
    495             TypeError: Argument 'cls' has incorrect type (expected type, got classobj)                                                        
    496     """                                                                                                                                       
--> 497     return (<PyTypeObject*>type).tp_call(cls, args, kwds)
    498
    499 # Class for timing::                                                                                                                          

TypeError: __init__() got an unexpected keyword argument 'implementation' 

This error in turn, goes away if I omit the implementation keyword:

sage: W = CoxeterGroup(['B', 3]) # optional - coxeter3                                                                                                
sage: W
Coxeter group of type ['B', 3] implemented by Coxeter3  

comment:3 in reply to: ↑ 1 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to mantepse:

The error goes away if I do a make afterwards...

Then it's not a bug.

comment:4 in reply to: ↑ 2 Changed 3 years ago by jdemeyer

Replying to mantepse:

However, now

sage: W = CoxeterGroup(['B', 3], implementation='coxeter3') # optional - coxeter3

Also works for me:

sage: W = CoxeterGroup(['B', 3], implementation='coxeter3')
sage: W
Coxeter group of type ['B', 3] implemented by Coxeter3

comment:5 Changed 3 years ago by mantepse

Where can I read that I have to run make after sage -i?

comment:6 Changed 3 years ago by jdemeyer

  • Resolution changed from wontfix to duplicate

Duplicate of #22197

Note: See TracTickets for help on using tickets.