Opened 3 years ago

Closed 3 years ago

#24422 closed defect (duplicate)

wrong coercion used

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: coercion Keywords:
Cc: jdemeyer Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

There is a highly optimized method _real_mpfi_ on quadratic number field elements. Though Sage prefers going through the call conversion

sage: K.<sqrt2> = QuadraticField(2, embedding=AA(2).sqrt())
sage: RIF.coerce_map_from(K)
Call morphism:
  From: Number Field in sqrt2 with defining polynomial x^2 - 2
  To:   Real Interval Field with 53 bits of precision

Change History (1)

comment:1 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24371.

Note: See TracTickets for help on using tickets.