Opened 3 years ago

Closed 3 years ago

#24419 closed defect (duplicate)

sage -rst2ipynb is broken due to notedown

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

$ cat a.rst
titre
-----

a::

    sage: 2+2
    4
$ sage -rst2ipynb a.rst
Traceback (most recent call last):
  File "/home/slabbe/GitBox/sage/local/bin/notedown", line 11, in <module>
    load_entry_point('notedown==1.5.0', 'console_scripts', 'notedown')()
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 561, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
    return ep.load()
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2291, in load
    return self.resolve()
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2297, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/notedown/__init__.py", line 8, in <module>
    from .contentsmanager import NotedownContentsManager
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/notedown/contentsmanager.py", line 8, in <module>
    from notebook.services.contents.filemanager import FileContentsManager
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/notebook/services/contents/filemanager.py", line 21, in <module>
    from .manager import ContentsManager
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/notebook/services/contents/manager.py", line 38, in <module>
    class ContentsManager(LoggingConfigurable):
  File "/home/slabbe/GitBox/sage/local/lib/python2.7/site-packages/notebook/services/contents/manager.py", line 70, in ContentsManager
    untitled_notebook = Unicode(_("Untitled"), config=True,
NameError: name '_' is not defined
notedown failed: 1

Moreover:

Using --optional=ccache,dot2tex,mpir,notedown,pandoc_attributes,pandocfilters,python2,rst2ipynb,sage
Doctesting 1 file.

...

----------------------------------------------------------------------
sage -t --warn-long 70.2 src/sage/tests/cmdline.py  # 5 doctests failed
----------------------------------------------------------------------

Change History (1)

comment:1 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24376

Note: See TracTickets for help on using tickets.