Opened 3 years ago

Closed 3 years ago

#24410 closed defect (duplicate)

comparison bug between real balls and real literals

Reported by: vdelecroix Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: mmezzarobba, jdemeyer, cheuberg Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: RBF(0) < -1.0
True

Change History (3)

comment:1 follow-up: Changed 3 years ago by mmezzarobba

Isn't it just an instance of #22029? Even if they are a bit special, real litterals are elements of RR...

comment:2 in reply to: ↑ 1 Changed 3 years ago by vdelecroix

Replying to mmezzarobba:

Isn't it just an instance of #22029? Even if they are a bit special, real litterals are elements of RR...

From the ticket description of #22029 it is hard to tell. But I believe that the answer is yes.

comment:3 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is because of

sage: coercion_model.canonical_coercion(RBF(0), -1.0)
---------------------------------------------------------------------------
TypeError                                 Traceback (most recent call last)
<ipython-input-3-bf5b7fb19950> in <module>()
----> 1 coercion_model.canonical_coercion(RBF(Integer(0)), -RealNumber('1.0'))

/usr/local/src/sage-config/src/sage/structure/coerce.pyx in sage.structure.coerce.CoercionModel_cache_maps.canonical_coercion (build/cythonized/sage/structure/coerce.c:12993)()
   1133         raise bin_op_exception(op, x, y)
   1134 
-> 1135     cpdef canonical_coercion(self, x, y):
   1136         r"""
   1137         Given two elements x and y, with parents S and R respectively,

/usr/local/src/sage-config/src/sage/structure/coerce.pyx in sage.structure.coerce.CoercionModel_cache_maps.canonical_coercion (build/cythonized/sage/structure/coerce.c:12888)()
   1276                 self._record_exception()
   1277 
-> 1278         raise TypeError("no common canonical parent for objects with parents: '%s' and '%s'"%(xp, yp))
   1279 
   1280 

TypeError: no common canonical parent for objects with parents: 'Real ball field with 53 bits of precision' and 'Real Field with 53 bits of precision'

So it's indeed sort-of a duplicate of #22029.

Note: See TracTickets for help on using tickets.