Opened 2 years ago

Closed 10 months ago

#24393 closed defect (invalid)

WeylGroup.subgroup doesn't create a subset

Reported by: vittucek Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers: Travis Scrimshaw, Simon Brandhorst
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The following code

W = WeylGroup("A2", prefix="s")
s = W.simple_reflections()
H = W.subgroup([s[2]])
s[2] in list(H)

returns False. One workaround is s[2] in list(W(x) for x in H).

Change History (6)

comment:1 Changed 2 years ago by vittucek

  • Summary changed from WeylGroup.subgroup is not a subset to WeylGroup.subgroup doesn't create a subset

comment:2 Changed 2 years ago by vittucek

Seems like a duplicate of #19010

comment:3 Changed 2 years ago by tscrim

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Reviewers set to Travis Scrimshaw
  • Status changed from new to needs_review

I agree that this is essentially a duplicate of #19010 as the root cause is the same:

sage: W.has_coerce_map_from(H)
False

Every subgroup should have a coercion into its ambient group.

comment:4 Changed 18 months ago by sbrandhorst

  • Status changed from needs_review to positive_review

indeed.

comment:5 Changed 18 months ago by sbrandhorst

  • Reviewers changed from Travis Scrimshaw to Travis Scrimshaw, Simon Brandhorst

comment:6 Changed 10 months ago by embray

  • Resolution set to invalid
  • Status changed from positive_review to closed

Presuming these are all correctly reviewed as either duplicate, invalid, or wontfix.

Note: See TracTickets for help on using tickets.