Opened 4 years ago

Closed 4 years ago

#24356 closed defect (fixed)

Upgrade openssl to 1.1.0g

Reported by: tmonteil Owned by:
Priority: blocker Milestone: sage-8.2
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Thierry Monteil Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 722e04a (Commits, GitHub, GitLab) Commit: 722e04af09d098d8fc4951f0c73cd528a098d9bb
Dependencies: Stopgaps:

Status badges

Description (last modified by tmonteil)

A security advisory appeared in openssl just after Sage 8.1 release. Since we are at the beginning of the next release, let us take the opportunity to upgrade from 1.0.2 to 1.1.0.

Tarball: https://www.openssl.org/source/openssl-1.1.0g.tar.gz

Change History (5)

comment:1 Changed 4 years ago by tmonteil

  • Branch set to u/tmonteil/upgrade_openssl_to_1_1_0g

comment:2 Changed 4 years ago by git

  • Commit set to 722e04af09d098d8fc4951f0c73cd528a098d9bb

Branch pushed to git repo; I updated commit sha1. New commits:

722e04a24356 : update openssl spkg-install

comment:3 Changed 4 years ago by tmonteil

  • Description modified (diff)
  • Priority changed from major to blocker
  • Status changed from new to needs_review

comment:4 Changed 4 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:5 Changed 4 years ago by vbraun

  • Branch changed from u/tmonteil/upgrade_openssl_to_1_1_0g to 722e04af09d098d8fc4951f0c73cd528a098d9bb
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.