Opened 3 years ago

Closed 3 years ago

#24329 closed defect (fixed)

Upgrade to pynac-0.7.14

Reported by: rws Owned by:
Priority: major Milestone: sage-8.2
Component: packages: standard Keywords:
Cc: fbissey Merged in:
Authors: Ralf Stephan Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: ad68aeb (Commits, GitHub, GitLab) Commit: ad68aeb0da6d58bc719d96b54fcc26e04ea9f34f
Dependencies: Stopgaps:

Status badges

Description (last modified by rws)

In 0.7.14:

  • fix subs regression (#24262)
  • improve inexact numerics (#24299, #24317)
  • (x^-a)^-b --> (x^a)^b, with a,b numeric > 0
  • fix mul of infinities (#24327)
  • implement has_function() (#24283)
  • use arb for inverse trig/hyperbolic funs
  • internally rename tgamma to gamma (affects print order)

In 0.7.13:

  • fix ex.coefficients() bugs (#23545, #24147)
  • fix interface to Singular GCD (#23845)
  • fix compiler warnings
  • asin/atan enhancements (#24211)
  • set_of_all() function (#24176)
  • upgrade ax_cxx_compile_stdcxx_11.m4

https://github.com/pynac/pynac/releases/download/pynac-0.7.14/pynac-0.7.14.tar.bz2

Change History (10)

comment:1 Changed 3 years ago by rws

  • Description modified (diff)

comment:2 Changed 3 years ago by rws

  • Dependencies set to #24318

comment:3 Changed 3 years ago by rws

  • Branch set to u/rws/upgrade_to_pynac_0_7_14

comment:4 Changed 3 years ago by git

  • Commit set to 9252fbd8d1bf8c8c651742c185ae2f527fbee962

Branch pushed to git repo; I updated commit sha1. New commits:

9252fbd24329: doctest additions, adaptations

comment:5 Changed 3 years ago by fbissey

  • Cc fbissey added

comment:6 Changed 3 years ago by rws

  • Description modified (diff)
  • Status changed from new to needs_review

Double upgrade since 0.7.13 doesn't make it into 8.2.beta1.

comment:7 Changed 3 years ago by git

  • Commit changed from 9252fbd8d1bf8c8c651742c185ae2f527fbee962 to ad68aeb0da6d58bc719d96b54fcc26e04ea9f34f

Branch pushed to git repo; I updated commit sha1. New commits:

ad68aebMerge branch 'develop' into t/24329/upgrade_to_pynac_0_7_14

comment:8 Changed 3 years ago by rws

  • Authors set to Ralf Stephan
  • Dependencies #24318 deleted

comment:9 Changed 3 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

Buildbots, come forth. :P

comment:10 Changed 3 years ago by vbraun

  • Branch changed from u/rws/upgrade_to_pynac_0_7_14 to ad68aeb0da6d58bc719d96b54fcc26e04ea9f34f
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.