Opened 2 years ago

Closed 2 years ago

#24213 closed enhancement (duplicate)

do not set MPLVERSION and MPLCONFIGDIR in sage-env

Reported by: was Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by was)

sage-env now contains two lines like this:

"$SAGE_LOCAL/bin/python" -c 'import pkg_resources; pkg_resources.get_distribution("matplotlib").version' 2>/dev/null

In a sage install with a moderately slow filesystem and a LOT of Python packages installed (e.g., cocalc), this line takes a while (for me, 1.5s). This means that sage-env takes 3s to load, which is ridiculous, as it should take a few ms. Running Python fully twice is wasteful.

Let's just not mess with the matplotlib path. It's very annoying wasting several seconds (for some users) during startup just because we want to hide from better integrating with system python. If the user really has conflicting matplotlib paths, just let them set the variable themselves.

Change History (4)

comment:1 Changed 2 years ago by jhpalmieri

I think this is a duplicate of #23711.

comment:2 Changed 2 years ago by was

  • Description modified (diff)

comment:3 Changed 2 years ago by jhpalmieri

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

I propose closing this as a duplicate.

comment:4 Changed 2 years ago by was

  • Resolution set to duplicate
  • Status changed from needs_review to closed

I agree -- I just wanted the typesetting to be right.

Note: See TracTickets for help on using tickets.