Opened 4 years ago

Closed 4 years ago

#24198 closed defect (fixed)

sage --notebook=export does not start

Reported by: egourgoulhon Owned by:
Priority: blocker Milestone: sage-8.1
Component: notebook Keywords:
Cc: jdemeyer, fbissey Merged in:
Authors: Jeroen Demeyer Reviewers: Eric Gourgoulhon
Report Upstream: N/A Work issues:
Branch: f8eef4e (Commits, GitHub, GitLab) Commit: f8eef4e91de33e4d1fb5132f06bec271e739e290
Dependencies: Stopgaps:

Status badges

Description (last modified by egourgoulhon)

In Sage 8.1.rc0, the command sage --notebook=export (default for sage --notebook) fails with

[C 14:16:56.066 NotebookApp] Bad config encountered during initialization:
[C 14:16:56.066 NotebookApp] The 'nbserver_extensions' trait of a NotebookApp instance must be a dict, but a value of type 'list' (i.e. ['sagenb_export.nbextension']) was specified.

(see attached file for full log).

Both sage --notebook=jupyter and sage --notebook=sagenb are OK though.

This is on Ubuntu 16.04 and ahs been reported at https://groups.google.com/d/msg/sage-release/7-eKF-xN0p0/z3T5zeMhAQAJ

NB: everything is OK with Sage 8.1.beta8, so the issue is most certainly due to a change introduced in Sage 8.1.beta9 or 8.1.rc0.

Attachments (1)

sage_notebook.log (4.6 KB) - added by egourgoulhon 4 years ago.
Log of "sage --notebook" command

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by egourgoulhon

Log of "sage --notebook" command

comment:1 Changed 4 years ago by egourgoulhon

  • Description modified (diff)

comment:2 Changed 4 years ago by egourgoulhon

  • Cc jdemeyer fbissey added

It seems that the issue is related to #24064, which has been merged in Sage 8.1.beta9: in the discussion of that ticket, there is mention of nbserver_extensions, which appears in the error message.

comment:3 Changed 4 years ago by jdemeyer

  • Authors set to Jeroen Demeyer

Sorry for messing this up...

I usually run ./sage -n jupyter, so that is why I did not notice this.

comment:4 Changed 4 years ago by jdemeyer

  • Branch set to u/jdemeyer/sage___notebook_export_does_not_start

comment:5 Changed 4 years ago by jdemeyer

  • Commit set to f8eef4e91de33e4d1fb5132f06bec271e739e290
  • Status changed from new to needs_review

The new format is a dict {module: enabled}.


New commits:

f8eef4eUse correct format for nbserver_extensions

comment:6 Changed 4 years ago by egourgoulhon

  • Reviewers set to Eric Gourgoulhon
  • Status changed from needs_review to positive_review

Thanks for the fix! (I've just checked it on my computer).

comment:7 Changed 4 years ago by vbraun

  • Branch changed from u/jdemeyer/sage___notebook_export_does_not_start to f8eef4e91de33e4d1fb5132f06bec271e739e290
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.