Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#24197 closed defect (duplicate)

Cygwin: fpylll fails to build

Reported by: charpent Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

See enclosed log.

Attachments (1)

fpylll-0.3.0dev.log (5.1 KB) - added by charpent 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by charpent

comment:1 Changed 3 years ago by charpent

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Turns out to be a duplicate of #24191.

comment:2 Changed 3 years ago by charpent

  • Status changed from needs_review to positive_review

Marking it as duplicate.

comment:3 Changed 3 years ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:4 Changed 3 years ago by embray

  • Component changed from packages: standard to porting: Cygwin
  • Summary changed from On Windows 10 + "Fall Creator update", fpylll fails to build. to Cygwin: fpylll fails to build

For what it's worth, in most cases naming a specific Windows version/update is not too relevant when it comes to Cygwin. Although there *can* be API changes between major versions of Windows that impact how Cygwin works, it's not often, and is not a likely area in which third-party bugs are likely to be discovered (though not impossible).

So most issues with compiling on Cygwin can just mention "Cygwin". A rare exception to this was #24121, but that's only because I was calling a built-in Windows command ver, so it had nothing directly to do with Cygwin.

Note: See TracTickets for help on using tickets.