Opened 4 years ago

Closed 4 years ago

#24191 closed defect (fixed)

fpylll broken on Cygwin, again

Reported by: embray Owned by:
Priority: blocker Milestone: sage-8.1
Component: porting: Cygwin Keywords: fpylll windows cygwin
Cc: Merged in:
Authors: Erik Bray Reviewers: Travis Scrimshaw, Jeroen Demeyer
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: 6150f9b (Commits, GitHub, GitLab) Commit: 6150f9b70dafd75e64b27b73848584cc2d179dda
Dependencies: Stopgaps:

Status badges

Description (last modified by embray)

Regression introduced by #24042 presumably.

[fpylll-0.3.0dev] Thread model: posix
[fpylll-0.3.0dev] gcc version 5.4.0 (GCC)
[fpylll-0.3.0dev] ****************************************************
[fpylll-0.3.0dev] Installing fpylll-0.3.0dev
[fpylll-0.3.0dev]
[fpylll-0.3.0dev] Error compiling Cython file:
[fpylll-0.3.0dev] ------------------------------------------------------------
[fpylll-0.3.0dev] ...
[fpylll-0.3.0dev]             Enumeration[Z_NR[long], FP_NR[dd_t]] *long_dd
[fpylll-0.3.0dev]             Enumeration[Z_NR[long], FP_NR[qd_t]] *long_qd
[fpylll-0.3.0dev]             Enumeration[Z_NR[long], FP_NR[mpfr_t]] *long_mpfr
[fpylll-0.3.0dev]     ELSE:
[fpylll-0.3.0dev]         ctypedef union enumeration_core_t:
[fpylll-0.3.0dev]             Enumeration[FP_NR[d_t]] *d
[fpylll-0.3.0dev]                        ^
[fpylll-0.3.0dev] ------------------------------------------------------------
[fpylll-0.3.0dev]
[fpylll-0.3.0dev] src/fpylll/fplll/decl.pxd:399:24: Enumeration templated type receives 2 arguments, got 1

and a few similar errors.

Upstream PR: https://github.com/fplll/fpylll/pull/105

Change History (11)

comment:1 Changed 4 years ago by embray

Looks like a trivial typo.

comment:2 Changed 4 years ago by embray

  • Authors set to Erik Bray
  • Branch set to u/embray/ticket-24191
  • Commit set to 1176e174dbbda0da4d32a29649f16b74cbbf0f31
  • Keywords fpylll windows cygwin added
  • Report Upstream changed from N/A to Not yet reported upstream; Will do shortly.
  • Status changed from new to needs_review

New commits:

1176e17Add patch fixing build errors in fpylll on Cygwin

comment:3 Changed 4 years ago by embray

  • Description modified (diff)
  • Report Upstream changed from Not yet reported upstream; Will do shortly. to Reported upstream. No feedback yet.

comment:4 Changed 4 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

Makes sense and LGTM.

comment:5 Changed 4 years ago by embray

  • Status changed from positive_review to needs_work

My patch has a small bug. See upstream PR.

comment:6 Changed 4 years ago by git

  • Commit changed from 1176e174dbbda0da4d32a29649f16b74cbbf0f31 to 6150f9b70dafd75e64b27b73848584cc2d179dda

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

6150f9bAdd patch fixing build errors in fpylll on Cygwin

comment:7 Changed 4 years ago by embray

Fixed patch; waiting for upstream CI report, but it should be good now.


New commits:

6150f9bAdd patch fixing build errors in fpylll on Cygwin

comment:8 Changed 4 years ago by embray

  • Report Upstream changed from Reported upstream. No feedback yet. to Reported upstream. Developers acknowledge bug.

comment:9 Changed 4 years ago by jdemeyer

  • Report Upstream changed from Reported upstream. Developers acknowledge bug. to Fixed upstream, but not in a stable release.

positive_review to adding the patch to Sage which was merged upstream.

comment:10 Changed 4 years ago by tscrim

  • Reviewers changed from Travis Scrimshaw to Travis Scrimshaw, Jeroen Demeyer
  • Status changed from needs_work to positive_review

Agreed.

comment:11 Changed 4 years ago by vbraun

  • Branch changed from u/embray/ticket-24191 to 6150f9b70dafd75e64b27b73848584cc2d179dda
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.