Opened 2 years ago

Closed 2 years ago

#24188 closed defect (duplicate)

CBC causes doctest failures because of linking with incompatible liblapack

Reported by: mderickx Owned by:
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

See the logs of quasar:

Relevant part of the logs:

File "src/sage/numerical/backends/coin_backend.pyx", line 1628, in sage.numerical.backends.coin_backend.CoinBackend.get_row_price
Failed example:
    p = get_solver(solver = "Coin")                  # optional - cbc
Exception raised:
    Traceback (most recent call last):
      File "/home/vdelecro/sage_patchbot/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 515, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/vdelecro/sage_patchbot/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 885, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.numerical.backends.coin_backend.CoinBackend.get_row_price[1]>", line 1, in <module>
        p = get_solver(solver = "Coin")                  # optional - cbc
      File "sage/numerical/backends/generic_backend.pyx", line 1650, in sage.numerical.backends.generic_backend.get_solver (build/cythonized/sage/numerical/backends/generic_backend.c:21055)
        cpdef GenericBackend get_solver(constraint_generation = False, solver = None, base_ring = None):
      File "sage/numerical/backends/generic_backend.pyx", line 1785, in sage.numerical.backends.generic_backend.get_solver (build/cythonized/sage/numerical/backends/generic_backend.c:20378)
        from sage.numerical.backends.coin_backend import CoinBackend
    ImportError: /usr/lib/liblapack.so.3: undefined symbol: sgetrs_N_parallel

Change History (3)

comment:1 Changed 2 years ago by tmonteil

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is a duplicate of #22006.

comment:2 Changed 2 years ago by mderickx

  • Status changed from needs_review to positive_review

comment:3 Changed 2 years ago by mderickx

  • Resolution set to duplicate
  • Status changed from positive_review to closed

Thanks for pointing this out.

Note: See TracTickets for help on using tickets.