Opened 3 years ago

Closed 4 months ago

#24165 closed defect (duplicate)

is_isomorphic returns false for some fields isomorphic to QQ

Reported by: edgarcosta Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: is_isomorphic, numberfields, QQ
Cc: Merged in:
Authors: Reviewers: Dave Morris
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: L.<b> = NumberField(x - 2)
....: F.<a> = NumberField(x)
....: print F.is_isomorphic(F)
....: print F.is_isomorphic(L)
....: print L.is_isomorphic(L)
....: 
False
False
True

Change History (3)

comment:1 Changed 4 months ago by gh-DaveWitteMorris

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Dave Morris
  • Status changed from new to needs_review

This is a duplicate of #26239, which was merged in 8.6.

comment:2 Changed 4 months ago by gh-DaveWitteMorris

  • Status changed from needs_review to positive_review

comment:3 Changed 4 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.