#24147 closed defect (wontfix)

Segfault with ex.coefficients

Reported by: rws Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #24262 Stopgaps:

Description (last modified by slelievre)

From https://groups.google.com/forum/#!topic/sage-devel/_amko6fGk64 :

sage: s = diff(function('f')(x), x) * x^2
sage: s.coefficients(x)  # Bam!

Upstream fix: https://github.com/pynac/pynac/issues/276

Change History (9)

comment:1 follow-up: Changed 19 months ago by rws

  • Dependencies set to pynac-0.7.13

Fixed in Pynac master.

comment:2 in reply to: ↑ 1 Changed 19 months ago by egourgoulhon

Replying to rws:

Fixed in Pynac master.

Thanks!

comment:3 Changed 18 months ago by slelievre

  • Description modified (diff)
  • Report Upstream changed from N/A to Fixed upstream, but not in a stable release.

comment:4 Changed 18 months ago by rws

  • Dependencies changed from pynac-0.7.13 to #24262
  • Report Upstream changed from Fixed upstream, but not in a stable release. to N/A

comment:5 Changed 18 months ago by charpent

Fixed by #24262, whose validation will allow me to give positive_review to the present ticket.

comment:6 Changed 18 months ago by rws

This ticket needs to doctest the issue.

comment:7 Changed 18 months ago by rws

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #23545 (which doctests both issues).

comment:8 Changed 18 months ago by rws

  • Status changed from needs_review to positive_review

comment:9 Changed 17 months ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.