Opened 5 years ago

Closed 3 years ago

#24084 closed defect (invalid)

Deprecated Ubuntu PPA; Pending update to Docs; Missing package for Ubuntu 17.10 Artful Aardvark

Reported by: rolandog Owned by: rolandog
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: distribution Keywords: ubuntu, ppa, repository, zesty, artful
Cc: vbraun Merged in:
Authors: Reviewers: Thierry Monteil
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

When I updated to Ubuntu Artful Aardvark (17.10), I noticed that SageMath was uninstalled.

After following the tutorial http://www.sagemath.org/download-linux.html, I was able to add the repository:

sudo -E apt-add-repository -y ppa:aims/sagemath
[sudo] password for rolandog: 
gpg: keybox '/tmp/tmpzk8nwevw/pubring.gpg' created
gpg: /tmp/tmpzk8nwevw/trustdb.gpg: trustdb created
gpg: key BDCB16CCBE796FF2: public key "Launchpad PPA for AIMS" imported
gpg: Total number processed: 1
gpg:               imported: 1
OK

However, upon executing the update command:

sudo -E apt-get update
Err:18 http://ppa.launchpad.net/aims/sagemath/ubuntu artful Release            
  404  Not Found
Reading package lists... Done                      
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386'
E: The repository 'http://ppa.launchpad.net/aims/sagemath/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

So, browsing the available dists, http://ppa.launchpad.net/aims/sagemath/ubuntu/dists/ I noticed they were quite out of date:

Index of /aims/sagemath/ubuntu/dists
[ICO]	Name		Last modified		Size	Description
[PARENTDIR]		Parent Directory	 	- 	 
[DIR]	devel/		2016-05-28 09:35 	- 	 
[DIR]	lucid/		2012-02-28 20:41 	- 	 
[DIR]	maverick/	2012-02-28 20:41 	- 	 
[DIR]	natty/		2012-02-28 20:41 	- 	 
[DIR]	oneiric/	2012-02-28 20:41 	- 	 
[DIR]	precise/	2012-02-28 18:15 	- 	 
[DIR]	quantal/	2012-11-17 07:20 	- 	 
[DIR]	raring/		2013-05-06 11:41 	- 	 
[DIR]	saucy/		2013-06-22 09:27 	- 	 
[DIR]	trusty/		2017-01-30 07:19 	- 	 
[DIR]	utopic/		2015-10-21 14:52 	- 	 
[DIR]	vivid/		2016-05-28 08:55 	- 	 
[DIR]	wily/		2016-05-28 08:55 	- 	 
[DIR]	xenial/		2017-02-07 09:52 	- 	 
[DIR]	yakkety/	2016-05-28 09:35 	- 	 

Upon visiting the AIMS https://launchpad.net/~aims launchpad landing page, sure enough, there is a notice that says:

AIMS-desktop is developed at the African Institute for Mathematical Sciences - South Africa (http://www.aims.ac.za), a centre for education and research in Cape Town, South Africa, and the first centre in the AIMS network.

The AIMS desktop PPAs listed here are deprecated. AIMS desktop is moving from an Ubuntu derivative to a Debian derivative. We expect to launch shortly after Debian Stretch is becomes the next stable release in 2017.

Watch this space: https://desktop.aims.ac.za/

We hope to continue updating the Sagemath PPA for Ubuntu on a best-effort basis, but Sage is available in Debian stretch (December 2016), so will be in Ubuntu from 17.04, or you can (manually) install the binaries from http://www.sagemath.org/download.html

After browsing in the sage-devel mailing list, I found the following email https://groups.google.com/d/topic/sage-devel/NoyVpYdYRAM/discussion where it is mentioned that current packages are now located in https://packages.ubuntu.com/zesty/math/ ... but, upon browsing it can be seen that sagemath isn't listed in https://packages.ubuntu.com/artful/math/

So, I enabled the Zesty Universe packages, and was able to 'see' the sagemath package https://packages.ubuntu.com/zesty/math/sagemath in Synaptic

However, upon attempting installation, I receive the following error message in Synaptic. The title of the warning says 'Could not mark all packages for installation or upgrade'. Followed by this description 'The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.'

sagemath:
 Depends: ecl but it is not going to be installed
 Depends: libbrial-groebner0 but it is not going to be installed
 Depends: libbrial0 but it is not going to be installed
 Depends: libcliquer1 but it is not going to be installed
 Depends: libec2 but it is not going to be installed
 Depends: libecm1 but it is not going to be installed
 Depends: libflint-2.5.2 but it is not going to be installed
 Depends: libflint-arb1 but it is not going to be installed
 Depends: libgap-sage-4 but it is not going to be installed
 Depends: libgivaro9 but it is not going to be installed
 Depends: libgmpxx4ldbl but it is not going to be installed
 Depends: libgsl2  but it is not installable
 Depends: libiml0 but it is not going to be installed
 Depends: liblfunction0 but it is not going to be installed
 Depends: liblinboxsage-1.4.2-0 but it is not going to be installed
 Depends: liblrcalc1 but it is not going to be installed
 Depends: libm4ri-0.0.20140914 but it is not going to be installed
 Depends: libm4rie-0.0.20150908 but it is not going to be installed
 Depends: libmpfi0 but it is not going to be installed
 Depends: libntl27 but it is not going to be installed
 Depends: libpari-gmp-tls5 but it is not going to be installed
 Depends: libplanarity0 but it is not going to be installed
 Depends: libppl14 but it is not going to be installed
 Depends: libpynac2 but it is not going to be installed
 Depends: libratpoints-2.1.3 but it is not going to be installed
 Depends: librw0 but it is not going to be installed
 Depends: libsingular4 but it is not going to be installed
 Depends: libsymmetrica2 but it is not going to be installed
 Depends: libzn-poly-0.9 but it is not going to be installed
 Depends: cysignals-tools but it is not going to be installed
 Depends: cython but it is not going to be installed
 Depends: eclib-tools but it is not going to be installed
 Depends: f2c but it is not going to be installed
 Depends: fflas-ffpack but it is not going to be installed
 Depends: flintqs but it is not going to be installed
 Depends: gap-core but it is not going to be installed
 Depends: gfan but it is not going to be installed
 Depends: gmp-ecm
 Depends: jmol but it is not going to be installed
 Depends: lcalc but it is not going to be installed
 Depends: libcdd-tools but it is not going to be installed
 Depends: libsingular4-dev but it is not going to be installed
 Depends: libsingular4-dev but it is not going to be installed
 Depends: maxima-sage but it is not going to be installed
 Depends: maxima-sage-doc but it is not going to be installed
 Depends: maxima-sage-share but it is not going to be installed
 Depends: nauty but it is not going to be installed
 Depends: octave but it is not going to be installed
 Depends: palp but it is not going to be installed
 Depends: pari-doc but it is not going to be installed
 Depends: pari-gp but it is not going to be installed
 Depends: pari-galdata but it is not going to be installed
 Depends: pari-seadata but it is not going to be installed
 Depends: python-backports.ssl-match-hostname but it is not going to be installed
 Depends: python-brial but it is not going to be installed
 Depends: python-cysignals-pari but it is not going to be installed
 Depends: python-flask but it is not going to be installed
 Depends: python-flask-autoindex but it is not going to be installed
 Depends: python-flask-babel but it is not going to be installed
 Depends: python-flask-oldsessions but it is not going to be installed
 Depends: python-flask-openid but it is not going to be installed
 Depends: python-flask-silk but it is not going to be installed
 Depends: python-fpylll but it is not going to be installed
 Depends: python-gd but it is not going to be installed
 Depends: python-gnutls but it is not going to be installed
 Depends: python-itsdangerous but it is not going to be installed
 Depends: python-moinmoin but it is not going to be installed
 Depends: python-networkx but it is not going to be installed
 Depends: python-openid but it is not going to be installed
 Depends: python-path but it is not going to be installed
 Depends: python-pip but it is not going to be installed
 Depends: python-pkgconfig but it is not going to be installed
 Depends: python-psutil but it is not going to be installed
 Depends: python-rpy2 but it is not going to be installed
 Depends: python-sagenb but it is not going to be installed
 Depends: python-sagenb-export but it is not going to be installed
 Depends: python-setuptools-scm but it is not going to be installed
 Depends: python-snowballstemmer but it is not going to be installed
 Depends: python-vcversioner but it is not going to be installed
 Depends: python-werkzeug but it is not going to be installed
 Depends: python-zodb but it is not going to be installed
 Depends: r-cran-lattice but it is not going to be installed
 Depends: r-base-dev but it is not going to be installed
 Depends: rubiks but it is not going to be installed
 Depends: sagemath-database-conway-polynomials but it is not going to be installed
 Depends: sagemath-database-elliptic-curves but it is not going to be installed
 Depends: sagemath-database-graphs but it is not going to be installed
 Depends: sagemath-database-mutually-combinatorial-designs but it is not going to be installed
 Depends: sagemath-database-polytopes but it is not going to be installed
 Depends: singular but it is not going to be installed
 Depends: singular but it is not going to be installed
 Depends: singular-doc but it is not going to be installed
 Depends: singular-doc but it is not going to be installed
 Depends: sympow (>= 1.023-8)
 Depends: tachyon but it is not going to be installed
 Depends: sagemath-common but it is not going to be installed
 Recommends: sagemath-doc-en but it is not going to be installed
 Recommends: sagemath-jupyter but it is not going to be installed
 Recommends: sagetex but it is not going to be installed

After trying in a terminal, I receive a terser log:

sudo apt-get install sagemath
[sudo] password for rolandog: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sagemath : Depends: libgsl2 but it is not installable
            Depends: libsingular4-dev (< 1:4.1) but 1:4.1.0-p3+ds-2 is to be installed
            Depends: python-cysignals-pari (>= 1.2.0+ds-2) but it is not going to be installed
            Depends: singular (< 1:4.1) but 1:4.1.0-p3+ds-2 is to be installed
            Depends: singular-doc (< 1:4.1) but 1:4.1.0-p3+ds-2 is to be installed
            Recommends: sagemath-doc-en but it is not going to be installed
            Recommends: sagemath-jupyter but it is not going to be installed
            Recommends: sagetex but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This is where I hit a wall and don't know where to proceed. I could manually force a lower version for the singular packages, but I already have the libgsl23 library installed, and this library is used by many other packages that are currently installed.

Any suggestions or workarounds?

Change History (9)

comment:1 Changed 5 years ago by rolandog

  • Priority changed from minor to major

Modified to major, since this basically means that users that upgraded to Ubuntu 17.10 can't install SageMath from the repository.

comment:2 Changed 5 years ago by rolandog

Should this be reported elsewhere, like in GSL https://www.gnu.org/software/gsl/ ?

comment:3 Changed 4 years ago by tmonteil

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Thierry Monteil
  • Status changed from new to needs_review

Indeed the PPA is not maintained anymore since the AIMS, which maintained that, moved to Debian.

However, Ubuntu 18.04 ships Sage directly, so let me suggest to upgrade to Ubuntu 18.04.

On the Sage side, we will not do anything to fix this issue so i suggest to close it.

comment:4 Changed 4 years ago by tmonteil

  • Status changed from needs_review to positive_review

comment:5 Changed 4 years ago by rolandog

  • Owner changed from (none) to rolandog

comment:6 Changed 4 years ago by rolandog

Hi Thierry,

It seems I may need assistance in closing the ticket.

These are the only fields I'm able to see in the Change Properties form:

Summary: 	
Description:
Type: 	
Priority: 	
Milestone: 	
Component: 	
Keywords: 		Cc: 	
Merged in: 		Authors: 	
Reviewers: 		Report Upstream: 	
Work issues: 		Branch: 	
Commit: 		Dependencies: 	
Stopgaps: 			

And these are the only actions I'm able to perform at the Action form:

leave as positive_review
needs info
needs work
resubmit to review
assign to
unassign
accept

I tried accepting it, thinking it may grant me permission to close it (change the Resolution and Status fields), but it seems I don't have enough permissions: https://trac.sagemath.org/wiki/TracTickets#edit-permissions.

comment:7 Changed 4 years ago by tmonteil

You are not supposed to close tickets, only the release manager is.

comment:8 Changed 3 years ago by slelievre

  • Cc vbraun added

Volker, please close.

comment:9 Changed 3 years ago by embray

  • Resolution set to invalid
  • Status changed from positive_review to closed

Presuming these are all correctly reviewed as either duplicate, invalid, or wontfix.

Note: See TracTickets for help on using tickets.