Change History (12)

comment:1 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 4 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_a_few_jupyter_packages

comment:3 Changed 4 years ago by git

  • Commit set to a0d75a0b162b18b744b67c145f3aef4434ac1bb4

Branch pushed to git repo; I updated commit sha1. New commits:

a0d75a0server_extensions is deprecated

comment:4 Changed 4 years ago by jdemeyer

  • Status changed from new to needs_review

comment:5 follow-up: Changed 4 years ago by fbissey

Which package introduce the deprecation of server_extension, do you know?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 4 years ago by jdemeyer

Replying to fbissey:

Which package introduce the deprecation of server_extension, do you know?

notebook (so it's not even a package touched on this ticket)

comment:7 in reply to: ↑ 6 Changed 4 years ago by fbissey

  • Reviewers set to François Bissey
  • Status changed from needs_review to positive_review

Replying to jdemeyer:

Replying to fbissey:

Which package introduce the deprecation of server_extension, do you know?

notebook (so it's not even a package touched on this ticket)

OK, that was puzzling me. Let's move it on.

comment:8 Changed 4 years ago by vbraun

  • Branch changed from u/jdemeyer/upgrade_a_few_jupyter_packages to a0d75a0b162b18b744b67c145f3aef4434ac1bb4
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:9 Changed 4 years ago by mderickx

  • Commit a0d75a0b162b18b744b67c145f3aef4434ac1bb4 deleted

At least three patchbots seem to fail during the build of ipykernel since 8.1.beta9. Could this ticket be the cause of that?

Most relevant part of the install log (which is messed up due to parallel builds)

[ipykernel-4.6.1]     Traceback (most recent call last):
[ipykernel-4.6.1]       File "<string>", line 1, in <module>
[ipykernel-4.6.1]       File "/tmp/pip-n397X9-build/setup.py", line 91, in <module>
[ipykernel-4.6.1]         from ipykernel.kernelspec import write_kernel_spec, make_ipkernel_cmd, KERNEL_NAME
[ipykernel-4.6.1]       File "ipykernel/__init__.py", line 2, in <module>
[ipykernel-4.6.1]         from .connect import *
[ipykernel-4.6.1]       File "ipykernel/connect.py", line 13, in <module>
[ipykernel-4.6.1]         from IPython.core.profiledir import ProfileDir
[ipykernel-4.6.1]       File "/opt/sage/local/lib/python2.7/site-packages/IPython/__init__.py", line 48, in <module>
[ipykernel-4.6.1]         from .core.application import Application
[ipykernel-4.6.1]       File "/opt/sage/local/lib/python2.7/site-packages/IPython/core/application.py", line 23, in <module>
[ipykernel-4.6.1]         from traitlets.config.application import Application, catch_config_error
[ipykernel-4.6.1]       File "/opt/sage/local/lib/python2.7/site-packages/traitlets/__init__.py", line 1, in <module>
[numpy-1.13.3.p0] gcc: numpy/core/src/npymath/npy_math.c
[ipykernel-4.6.1]         from .traitlets import *
[ipykernel-4.6.1]       File "/opt/sage/local/lib/python2.7/site-packages/traitlets/traitlets.py", line 60, in <module>
[ipykernel-4.6.1]         from .utils.importstring import import_item
[ipykernel-4.6.1]       File "/opt/sage/local/lib/python2.7/site-packages/traitlets/utils/importstring.py", line 8, in <module>
[ipykernel-4.6.1]         from ipython_genutils.py3compat import cast_bytes_py2
[ipykernel-4.6.1]     ImportError: No module named ipython_genutils.py3compat

Seems that somehow a dependency is not installed correctly.

comment:10 Changed 4 years ago by fbissey

Yes, those things can go unnoticed. According to similar gentoo ebuild ipykernel depends on traitlets which brings ipython_genutils, we don't have the traitlets dependency in ipykernel in sage. But I'd say the ipython_genutils is now a direct dependency in view of these logs.

comment:11 Changed 4 years ago by fbissey

I'd happily review a follow up ticket fixing this.

comment:12 Changed 4 years ago by mderickx

Ok, in the mean time I created the ticket #24088 for the issue.

Note: See TracTickets for help on using tickets.