Opened 2 years ago

Closed 2 years ago

#24063 closed enhancement (fixed)

Upgrade numpy

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-8.1
Component: packages: standard Keywords:
Cc: infinity0, fbissey Merged in:
Authors: Jeroen Demeyer Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: bfb8061 (Commits) Commit: bfb8061c316a0fc30ebd1730073f0cacf5d77539
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Debian already uses Numpy 1.13. We need two fixes:

  1. Avoid a few numpy calls in matrix_double_dense.pyx which we never needed in the first place.
  1. Silence a deprecation warning caused by combining our old matplotlib with this new numpy.

Tarball: https://pypi.python.org/packages/bf/2d/005e45738ab07a26e621c9c12dc97381f372e06678adf7dc3356a69b5960/numpy-1.13.3.zip

Change History (7)

comment:1 Changed 2 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_numpy

comment:2 Changed 2 years ago by git

  • Commit set to bfb8061c316a0fc30ebd1730073f0cacf5d77539

Branch pushed to git repo; I updated commit sha1. New commits:

bfb8061Silence warnings from old matplotlib + new numpy

comment:3 Changed 2 years ago by jdemeyer

  • Description modified (diff)
  • Status changed from new to needs_review

comment:4 Changed 2 years ago by jdemeyer

  • Cc infinity0 fbissey added

comment:5 Changed 2 years ago by fbissey

  • Reviewers set to François Bissey
  • Status changed from needs_review to positive_review

LGTM.

comment:6 Changed 2 years ago by infinity0

Works for me too, thanks!

comment:7 Changed 2 years ago by vbraun

  • Branch changed from u/jdemeyer/upgrade_numpy to bfb8061c316a0fc30ebd1730073f0cacf5d77539
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.