Opened 5 years ago

Closed 5 years ago

#24060 closed enhancement (fixed)

change some imports of misc

Reported by: chapoton Owned by:
Priority: major Milestone: sage-8.1
Component: python3 Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: David Roe
Report Upstream: N/A Work issues:
Branch: 0e4811e (Commits, GitHub, GitLab) Commit: 0e4811edbd75197877b6b50c52d2027592afce5f
Dependencies: #24055 Stopgaps:

Status badges

Description

to avoid some circular imports; that prevent "python -3" to work

Change History (17)

comment:1 Changed 5 years ago by chapoton

Branch: u/chapoton/24060
Commit: 3eb94e92ec252c3f8dd8aa7bf5305fdfbb08a111
Status: newneeds_review

New commits:

3eb94e9fixing some imports of misc

comment:2 Changed 5 years ago by git

Commit: 3eb94e92ec252c3f8dd8aa7bf5305fdfbb08a1119566e11bdda89113cced0d3d6ef1f26cb6e27b4a

Branch pushed to git repo; I updated commit sha1. New commits:

9566e11Merge branch 'u/chapoton/24060' in 8.1.b8

comment:3 Changed 5 years ago by jdemeyer

According to the one patchbot, it doesn't apply. But the Trac plugin says that it does.

comment:4 Changed 5 years ago by jdemeyer

I assume that the problem is with the patchbot, since the conflicting file (map_reduce.py) is not touched by this ticket.

comment:5 Changed 5 years ago by chapoton

I just rebased it immediatly after posting,so the patchbot must have taken the bad version

comment:6 Changed 5 years ago by jdemeyer

Dependencies: #24055
Status: needs_reviewneeds_work

Funny, this one:

bool(misc.mul([x.valuation(p) >= 0 for x in self.ainvs()]))

It shows a particular way of thinking by mathematicians.

This will conflict with #24055.

comment:7 Changed 5 years ago by git

Commit: 9566e11bdda89113cced0d3d6ef1f26cb6e27b4ab21b67f6aaec7179ef33ba0943b156a229935a94

Branch pushed to git repo; I updated commit sha1. New commits:

639eec1fixing use of forall
9cf9941Merge branch 'u/chapoton/24055' in 8.1.b8
b21b67fMerge branch 'u/chapoton/24060' in 24055

comment:8 Changed 5 years ago by chapoton

Status: needs_workneeds_review

I merged the branch with #24055


New commits:

639eec1fixing use of forall
9cf9941Merge branch 'u/chapoton/24055' in 8.1.b8
b21b67fMerge branch 'u/chapoton/24060' in 24055

New commits:

639eec1fixing use of forall
9cf9941Merge branch 'u/chapoton/24055' in 8.1.b8
b21b67fMerge branch 'u/chapoton/24060' in 24055

comment:9 Changed 5 years ago by jdemeyer

Status: needs_reviewneeds_work

This is failing on the patchbot...

comment:10 Changed 5 years ago by git

Commit: b21b67f6aaec7179ef33ba0943b156a229935a940e4811edbd75197877b6b50c52d2027592afce5f

Branch pushed to git repo; I updated commit sha1. New commits:

a8cb24aMerge branch 'u/chapoton/24060' in 8.1.b9
0e4811etrac 24060 one step backward

comment:11 Changed 5 years ago by chapoton

Status: needs_workneeds_review

tentative fix, let us see if the patchbots approve


New commits:

a8cb24aMerge branch 'u/chapoton/24060' in 8.1.b9
0e4811etrac 24060 one step backward

New commits:

a8cb24aMerge branch 'u/chapoton/24060' in 8.1.b9
0e4811etrac 24060 one step backward

comment:12 Changed 5 years ago by jdemeyer

Do you know what goes wrong in Python 3? Can you post the traceback?

comment:13 Changed 5 years ago by chapoton

This is not strictly related to python3-build, only to allow the use of "python -3" diagnostic tool with a python2-build.

I once observed something when typing "python -3 src/sage/all.py" in sage-shell. But I cannot manage to reproduce what I remember.

comment:14 Changed 5 years ago by jdemeyer

If this is fixing a problem that you cannot reproduce, shouldn't we just close this ticket as invalid?

comment:15 Changed 5 years ago by chapoton

Well, I would still prefer to have these more specific imports..

comment:16 Changed 5 years ago by roed

Reviewers: David Roe
Status: needs_reviewpositive_review

I think the changes are fine. Jeroen, if you object, feel free to set this back to Needs Work.

comment:17 Changed 5 years ago by vbraun

Branch: u/chapoton/240600e4811edbd75197877b6b50c52d2027592afce5f
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.