Opened 5 years ago

Closed 5 years ago

#23802 closed defect (wontfix)

Ncurses crash with x.abc?

Reported by: rws Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Any attempt to get online help (for example x.n?) crashes Sage. I'm assuming this is system-specific because noone has reported it yet. Gdb backtrace:

#0  0x00007ffdb9087ba2 in _nc_init_acs_sp () from /lib64/libtinfo.so.5
#1  0x00007ffd9b8d7f25 in _nc_setupscreen_sp ()
   from /home/ralf/sage/local/lib/libncursesw.so.6
#2  0x00007ffd9b8d37ff in newterm_sp ()
   from /home/ralf/sage/local/lib/libncursesw.so.6
#3  0x00007ffd9b8d00b3 in initscr ()
   from /home/ralf/sage/local/lib/libncursesw.so.6
#4  0x00007ffd9bafddc6 in PyCurses_InitScr (self=<optimized out>)
    at Modules/_cursesmodule.c:1943
#5  0x00007ffff7ace2c7 in call_function (oparg=<optimized out>, 
    pp_stack=0x7fffffffa840) at Python/ceval.c:4336
Python Exception <class 'gdb.error'> Cannot convert value to int.: 

Change History (5)

comment:1 Changed 5 years ago by jdemeyer

It might be relevant to mention which kind of terminal you use.

comment:2 Changed 5 years ago by jdemeyer

And does the problem occur with all terminals (say, xterm or pure console session at /dev/tty1)?

comment:3 Changed 5 years ago by rws

  • Milestone changed from sage-8.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review
  • Summary changed from Ncurses crash with x.abc? on OpenSuSE to Ncurses crash with x.abc?

This completely disappeared, somewhat after I deleted my $HOME/.sage directory (which I did because I could no longer start Sage). So I guess the cause was corruption of one of the files in that directory.

comment:4 Changed 5 years ago by rws

  • Status changed from needs_review to positive_review

comment:5 Changed 5 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.