Opened 2 years ago

Closed 2 years ago

#23732 closed defect (fixed)

Downgrade libtheora package to experimental

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-8.1
Component: packages: experimental Keywords:
Cc: whuss Merged in:
Authors: Maarten Derickx Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: 0fe2e6e (Commits) Commit: 0fe2e6e70a32b9070c463314f00367c107072f35
Dependencies: Stopgaps:

Description (last modified by mderickx)

The first error occurs during

make Theora.pdf which is defined in $THEORA_SOURCE/doc/spec/Makefile. Changing the two occurences of \begin{figure}[Htbp] to \begin{figure}[htbp] in doc/spec/spec.tex solves this issue but now it is stuc at a more serious problem:

png2theora.c:465:20: warning: implicit declaration of function 'png_sizeof' [-Wimplicit-function-declaration]
     3*height*width*png_sizeof(*row_data));
                    ^
png2theora.c:465:31: warning: 'row_data' may be used uninitialized in this function [-Wmaybe-uninitialized]
     3*height*width*png_sizeof(*row_data));
                               ^
png2theora.c:393:13: note: 'row_data' was declared here
   png_bytep row_data;
             ^
png2theora.c:467:12: warning: 'row_pointers' may be used uninitialized in this function [-Wmaybe-uninitialized]
     height*png_sizeof(*row_pointers));
            ^
png2theora.c:394:14: note: 'row_pointers' was declared here
   png_bytep *row_pointers;
              ^
/bin/bash ../libtool --mode=link gcc -I/users/derickx/sage_test/local/include   -Wall -Wno-parentheses -O3 -fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops   -L/users/derickx/sage_test/local/lib -Wl,-rpath,/users/derickx/sage_test/local/lib  -o png2theora  png2theora-png2theora.o  ../lib/libtheoraenc.la ../lib/libtheoradec.la -L/users/derickx/sage_test/local/lib -logg   -L/users/derickx/sage_test/local/lib -lpng16   -lm 
libtool: link: gcc -I/users/derickx/sage_test/local/include -Wall -Wno-parentheses -O3 -fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops -Wl,-rpath -Wl,/users/derickx/sage_test/local/lib -o .libs/png2theora png2theora-png2theora.o  -L/users/derickx/sage_test/local/lib ../lib/.libs/libtheoraenc.so ../lib/.libs/libtheoradec.so -logg -lpng16 -lm -Wl,-rpath -Wl,/users/derickx/sage_test/local/lib
png2theora-png2theora.o: In function `png_read':
png2theora.c:(.text+0x20d): undefined reference to `png_sizeof'
png2theora.c:(.text+0x230): undefined reference to `png_sizeof'
collect2: error: ld returned 1 exit status
Makefile:290: recipe for target 'png2theora' failed
make[2]: *** [png2theora] Error 1
make[2]: Leaving directory '/users/derickx/sage_test/local/var/tmp/sage/build/libtheora-1.1.1/src/examples'
Makefile:291: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/users/derickx/sage_test/local/var/tmp/sage/build/libtheora-1.1.1/src'
Makefile:205: recipe for target 'all' failed
make: *** [all] Error 2
Error building libtheora

this seems to be because png_sizeof was removed from lib_png version 1.6.0, see [1] and we ship lib_png 1.6.29.

[1] https://github.com/glennrp/libpng/blob/libpng16/CHANGES#L4206

this ticket also has attached the full log.

Attachments (1)

libtheora-1.1.1.log (56.0 KB) - added by tmonteil 2 years ago.

Download all attachments as: .zip

Change History (14)

Changed 2 years ago by tmonteil

comment:1 Changed 2 years ago by mderickx

  • Description modified (diff)

comment:2 Changed 2 years ago by mderickx

  • Priority changed from major to blocker

comment:3 Changed 2 years ago by mderickx

  • Cc whuss added

Added the package maintainer in the CC

comment:4 Changed 2 years ago by jdemeyer

  • Priority changed from blocker to major

An optional package failing to build should in general not be a blocker, unless maybe if it is a recent regression. I only said that optional packages causing doctest failures (or more general breakage) should be blockers.

comment:5 Changed 2 years ago by mderickx

I have looked a bit into this, and I could not find a place where this package actually enhances the sage library so this would just be a package that is easy to install in sage the distribution. However I don't really see what the reason is to have this package in "sage the distribution" without some easy user accecible way to generate fancy movies out of sage output. So one solution might even be to remove this from the optional packages and make it into an experimental one.

Does either of you agree with this? If so I will ask on sage-devel if people agree with this.

comment:6 Changed 2 years ago by mderickx

Aditionally the ticket where this package was added #7297 does not provide a good motivation about why it should be added.

comment:7 Changed 2 years ago by jdemeyer

Proposal: downgrade to experimental

comment:8 Changed 2 years ago by mderickx

  • Branch set to public/23732
  • Commit set to 0fe2e6e70a32b9070c463314f00367c107072f35

Here a trivial patch performing the downgrade. It can already be reviewed from a technical point of view. But this ticket should only be given positive review after the consensus on the sage-devel topic I opened for this is that it is indeed ok to downgrade this package to experimental:


New commits:

0fe2e6eTrac 23732: Downgrade libtheora to experimental package

comment:9 Changed 2 years ago by mderickx

  • Authors set to Maarten Derickx

comment:10 Changed 2 years ago by jdemeyer

  • Component changed from packages: optional to packages: experimental
  • Summary changed from libtheora fails to build on 32 bit Debian stretch to Downgrade libtheora package to experimental

comment:11 Changed 2 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

comment:12 Changed 2 years ago by jdemeyer

  • Status changed from needs_review to positive_review

Nobody complained about downgrading to experimental...

comment:13 Changed 2 years ago by vbraun

  • Branch changed from public/23732 to 0fe2e6e70a32b9070c463314f00367c107072f35
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.