Opened 23 months ago

Closed 6 months ago

#23417 closed enhancement (duplicate)

fast construction of symbolic sums

Reported by: rws Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by rws)

In legendre_P::eval_pari there is this:

return sum(b * arg**a for a, b in enumerate(pol))

Due to GiNaC::add::eval mechanics it has quadratic performance, fortunately eased by smart pointer operations. Much better however would be to have the iterator add to an GiNaC::exvector and construct the GiNaC::add from that. There is GExVector.push_back and g_add_construct in the Pynac interface already available.

Change History (5)

comment:1 Changed 17 months ago by rws

  • Description modified (diff)
  • Milestone changed from sage-8.1 to sage-8.2

comment:2 Changed 16 months ago by rws

  • Status changed from new to needs_review

Duplicate of #24553.

comment:3 Changed 16 months ago by rws

  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix

comment:4 Changed 12 months ago by mmezzarobba

  • Status changed from needs_review to positive_review

comment:5 Changed 6 months ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.