Opened 2 years ago

Closed 23 months ago

#23217 closed defect (fixed)

yasm testsuite fails

Reported by: vbraun Owned by:
Priority: minor Milestone: sage-8.1
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Erik Bray Reviewers: Jeroen Demeyer
Report Upstream: Reported upstream. No feedback yet. Work issues:
Branch: 1ae1262 (Commits) Commit: 1ae12629b46bd92f6107c57dd7a956d305fd89c5
Dependencies: Stopgaps:

Description (last modified by embray)

Sometimes when I build yasm in clean install with SAGE_CHECK=yes one or two tests fail. I've repeated this a few times and the failures I've seen are:

[yasm-1.3.0] FAIL: modules/preprocs/raw/tests/rawpp_test.sh
[yasm-1.3.0] FAIL: modules/objfmts/elf/tests/x32/elf_x32_test.sh
[yasm-1.3.0] FAIL: modules/objfmts/elf/tests/amd64/elf_amd64_test.sh

Sometimes it passes with no failures. My guess is it's more likely a problem with the tests than anything to do with Sage, but thought I'd make a note of it.

Upstream bug report: https://github.com/yasm/yasm/issues/87

Change History (6)

comment:1 Changed 2 years ago by embray

  • Description modified (diff)
  • Milestone sage-8.0 deleted
  • Priority changed from major to minor

I was about to open a ticket about this too. Here's my expanded description. Note: The failure seems to be non-deterministic.

comment:2 Changed 23 months ago by jhpalmieri

I've seen this once, too, on OS X:

[yasm-1.3.0] FAIL: modules/preprocs/raw/tests/rawpp_test.sh

comment:3 Changed 23 months ago by embray

  • Description modified (diff)
  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

This bug report seems to be the same issue: https://github.com/yasm/yasm/issues/87 I already confirmed that without running a parallel make job I can't reproduce the issue. But with parallel make, the more jobs I add the more likely it is to fail.

I also got a failure in the rawpp_test.sh one once.

comment:4 Changed 23 months ago by embray

  • Authors set to Erik Bray
  • Branch set to u/embray/ticket-23217
  • Commit set to 1ae12629b46bd92f6107c57dd7a956d305fd89c5
  • Milestone set to sage-8.1
  • Status changed from new to needs_review

I don't think the exact cause of this is worth investigating too deeply, but this seems to be a reliable workaround.


New commits:

1ae1262Force 'make -j1' when runnign the yasm test suite to avoid non-deterministic failures

comment:5 Changed 23 months ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:6 Changed 23 months ago by vbraun

  • Branch changed from u/embray/ticket-23217 to 1ae12629b46bd92f6107c57dd7a956d305fd89c5
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.