Opened 5 years ago

Closed 5 years ago

#23151 closed enhancement (fixed)

more typos in internal links syntax

Reported by: chapoton Owned by:
Priority: minor Milestone: sage-8.0
Component: documentation Keywords:
Cc: tscrim, jmantysalo Merged in:
Authors: Frédéric Chapoton Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: c09253c (Commits, GitHub, GitLab) Commit: c09253cf02a9ca4d4ce71396529da1fecd747517
Dependencies: Stopgaps:

Status badges

Description

similar to #23113

Change History (8)

comment:1 Changed 5 years ago by chapoton

  • Branch set to u/chapoton/23151
  • Cc tscrim jmantysalo added
  • Commit set to 0a77f92c0a66d043ba64630c8ac03253fae43cc2
  • Status changed from new to needs_review

easy one, I think


New commits:

0a77f92correct a few broken links in :meth:, :func:, :class:

comment:2 Changed 5 years ago by chapoton

  • Component changed from python3 to documentation

comment:3 Changed 5 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

LGTM.

comment:4 Changed 5 years ago by jhpalmieri

  • Status changed from positive_review to needs_info

Some issues (not necessarily caused by the changes here):

  • The reference manual page for sage/combinat/root_system/type_marked.py is missing from the table of contents. If I visit the page for sage/combinat/root_system/type_reducible.html, for example, then the one for type_marked.py is listed as being the previous topic, but it's not actually listed on the combinat table of contents. Any ideas why?
  • The change in sage/combinat/cluster_algebra_quiver/quiver.py fixes the mark-up, but the link is not valid. search_def('save_exceptional_data') comes up empty, so I can't tell what was intended.
  • Similarly, the change in sage/geometry/polyhedron/base.py yields a broken link.
  • Same with the change in sage/schemes/generic/algebraic_scheme.py.

Feel free to change back to "positive review" if you think these should be dealt with elsewhere.

comment:5 Changed 5 years ago by git

  • Commit changed from 0a77f92c0a66d043ba64630c8ac03253fae43cc2 to c09253cf02a9ca4d4ce71396529da1fecd747517

Branch pushed to git repo; I updated commit sha1. New commits:

c09253ctrac 23151 correct some broken links

comment:6 Changed 5 years ago by chapoton

  • Status changed from needs_info to needs_review

I tried to fix some of them, but this is not the aim of the ticket, indeed.

comment:7 Changed 5 years ago by chapoton

  • Status changed from needs_review to positive_review

ok, setting back to positive.

comment:8 Changed 5 years ago by vbraun

  • Branch changed from u/chapoton/23151 to c09253cf02a9ca4d4ce71396529da1fecd747517
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.