Opened 3 years ago

Closed 2 years ago

#23072 closed defect (wontfix)

Long doctest of usually fast series computation

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: performance Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

This is a followup on #14878. On the Sage commandline sin(x*sin(x*sin(x*sin(x)))).series(x,12) takes only about 100 microseconds; when doctesting in most of attempts it takes two hundred seconds (regardless of parallel or not). This possibly means changing memory content influences a computation.

While it influences patchbot time only atm (adds about 0.4% to overall CPU time) it's a serious cumulative waste, and it points to a hiding bug.

Change History (4)

comment:1 Changed 3 years ago by rws

Interestingly with the #22959 branch the behaviour changes, at least here. So file content changes memory content which (presumably) changes behaviour.

comment:2 Changed 3 years ago by rws

  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Probably a duplicate of #22733 and, if so, fixed in Pynac master.

comment:3 Changed 3 years ago by rws

  • Status changed from needs_review to positive_review

comment:4 Changed 2 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.