Opened 4 years ago

Closed 4 years ago

#23061 closed PLEASE CHANGE (duplicate)

Cardinality() of Elliptic Curve doesn't use Pari

Reported by: 6MON Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: elliptic curves Keywords: elliptic curves pari order cardinality sea baby step giant bsgs
Cc: defeo, erousseau Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Cardinality of Elliptic Curve doesn't use Pari. It probably uses "Baby step - Giant step" algorithm.

It takes a lot of time to compute the cardinality for a curve with log_2(p) = 128.

The problem is fixed using E._pari_().ellsea().

Change History (2)

comment:1 Changed 4 years ago by 6MON

  • Cc erousseau added

comment:2 Changed 4 years ago by jdemeyer

  • Authors 6MON deleted
  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16931.

Note: See TracTickets for help on using tickets.