Opened 13 years ago

Closed 13 years ago

#2306 closed defect (duplicate)

Tab completion in the command-line mode

Reported by: ljpk Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

When I use tab-complete in the command-line interface when typing an object name, the cursor moves to one space after the end of the name. This is unwanted behaviour, because this means that one cannot then type "." and tab-complete again to get the list of functions associated to the object.

Change History (12)

comment:1 Changed 13 years ago by mabshoff

  • Milestone set to sage-2.10.3

comment:2 Changed 13 years ago by jason

tab completion works correctly for me (Ubuntu 7.10, 32-bit), i.e., no space after pressing tab.

comment:3 Changed 13 years ago by ljpk

OK, so I should clarify that this is for the Windows-via-VMware version 2.10.1 (as just downloaded this evening).

comment:4 Changed 13 years ago by was

Are you typing directly into the vmware machine, or did you ssh into it via putty or something?

comment:5 Changed 13 years ago by was

It works fine for me on the vmware image (run from OS X) directly typing into vmware.

comment:6 Changed 13 years ago by ljpk

This is directly typing in to the vmware machine.

comment:7 Changed 13 years ago by jason

In 2.9.3, tab completion did not put a space after the command (Ubuntu 7.10, 32-bit).

However I am seeing this problem in 2.10.2, which, as the original poster mentioned, is annoying and slightly frustrating.

comment:8 Changed 13 years ago by gfurnish

  • Summary changed from Tab completion in the command-line mode to [invalid?] Tab completion in the command-line mode

Is this still an issue?

comment:9 Changed 13 years ago by jason

  • Summary changed from [invalid?] Tab completion in the command-line mode to Tab completion in the command-line mode

Yes. I am seeing this on a home-compiled Sage 3.0.4 on Ubuntu 8.04.

comment:11 Changed 13 years ago by jason

#2469 is another ticket for this issue.

comment:12 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.1.3 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as a dupe of #2469 since that ticket has the better explanation.

Cheers,

Michael

Note: See TracTickets for help on using tickets.