Opened 5 years ago

Closed 5 years ago

#23053 closed defect (fixed)

database_gap doesn't work after installing it

Reported by: jdemeyer Owned by:
Priority: blocker Milestone: sage-8.0
Component: packages: optional Keywords:
Cc: dimpase Merged in:
Authors: Volker Braun Reviewers: Jeroen Demeyer, Paul Zimmermann
Report Upstream: N/A Work issues:
Branch: d76bfb2 (Commits, GitHub, GitLab) Commit: d76bfb23ecd68b9567e941e9fafcd0b00939f864
Dependencies: Stopgaps:

Status badges

Description (last modified by zimmerma)

Reported by Paul Zimmermann and confirmed by me:

With Sage 7.6, after having done sage -i database_gap, I get:

sage: is_package_installed("database_gap")
True
sage: x = polygen(QQ); (x^5 - x - 1).galois_group()
verbose 0 (2061: permgroup_named.py, cardinality) Warning: TransitiveGroups requires the GAP database package. Please install it with `sage -i database_gap`.
[...]

Change History (25)

comment:1 Changed 5 years ago by zimmerma

it worked (for me) with Sage 7.5.1.

comment:2 follow-up: Changed 5 years ago by dimpase

Probably you need to force the re-creation of GAP workspaces. I thought all this was fixed in #22570...

What is the output of

sage: gap_console()

in your case?

comment:3 follow-up: Changed 5 years ago by dimpase

Also, does it go away if you install gap_packages() ?

comment:4 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:5 in reply to: ↑ 2 Changed 5 years ago by jdemeyer

Replying to dimpase:

What is the output of

sage: gap_console()

in your case?

 ┌───────┐   GAP 4.8.6, 12-Nov-2016, build of 2017-05-22 13:45:59 (CEST)
 │  GAP  │   http://www.gap-system.org
 └───────┘   Architecture: x86_64-unknown-linux-gnu-gcc-default64
 Libs used:  gmp, readline
 Loading the library and packages ...
 Packages:   GAPDoc 1.5.1
 Try '??help' for help. See also '?copyright', '?cite' and '?authors'

comment:6 in reply to: ↑ 3 Changed 5 years ago by jdemeyer

Replying to dimpase:

Also, does it go away if you install gap_packages() ?

No. I also tried to re-installed various GAP-related packages (gap itself, libgap, database_gap, gap_packages) but that didn't help either.

comment:7 Changed 5 years ago by dimpase

I don't know, it works for me in a recent beta.

Could you remove ~/.sage/gap/ and re-try gap_console() ?

comment:8 Changed 5 years ago by dimpase

Oops, I spoke too soon. Unlike you, I do see

Components: trans 1.0, prim 2.1, small* 1.0, id* 1.0

in gap_console() output, which should indicate that database_gap has been loaded etc., but I still get the error as indicated in the ticket description. Could it be that it's not really related to GAP?

Last edited 5 years ago by dimpase (previous) (diff)

comment:9 Changed 5 years ago by zimmerma

after I remove ~/.sage/gap/ it works with Sage 7.6:

┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 7.6, Release Date: 2017-03-25                     │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
sage: is_package_installed("database_gap")
True
sage: x = polygen(QQ); (x^5 - x - 1).galois_group()
Transitive group number 5 of degree 5

comment:10 Changed 5 years ago by zimmerma

  • Description modified (diff)

comment:11 Changed 5 years ago by dimpase

OK, so on the installation I was getting that error, removing ~/.sage/gap/ also makes it work. Apparently one can have different levels of brokenness:

  • no workspaces rebuilt
  • workspaces needed for console gap are rebuilt, but not the ones needed for the issue at hand.

comment:12 Changed 5 years ago by vbraun

  • Branch set to u/vbraun/database_gap_doesn_t_work_after_installing_it

comment:13 Changed 5 years ago by vbraun

  • Authors set to Volker Braun
  • Branch u/vbraun/database_gap_doesn_t_work_after_installing_it deleted
  • Status changed from new to needs_review

comment:14 Changed 5 years ago by dimpase

  • Branch set to u/vbraun/database_gap_doesn_t_work_after_installing_it
  • Commit set to d76bfb23ecd68b9567e941e9fafcd0b00939f864

I suppose branch deletion was a typo... :-)


New commits:

d76bfb2Add gap packages to the timestamps used for the workspace

comment:15 Changed 5 years ago by dimpase

Looks good to me. Any more interested parties to try this?

comment:16 follow-up: Changed 5 years ago by zimmerma

Looks good to me. Any more interested parties to try this?

I'd like to try the patch, but I don't know how. I have Sage 7.6 installed.

comment:17 in reply to: ↑ 16 Changed 5 years ago by dimpase

Replying to zimmerma:

Looks good to me. Any more interested parties to try this?

I'd like to try the patch, but I don't know how. I have Sage 7.6 installed.

build from scratch, perhaps?

git clone  git@trac.sagemath.org:sage.git
cd sage
git pull origin u/vbraun/database_gap_doesn_t_work_after_installing_it
./configure
MAKE="make -j8" make

etc

comment:18 follow-up: Changed 5 years ago by zimmerma

thanks. I guess I have to type autoreconf -i before ./configure.

comment:19 in reply to: ↑ 18 ; follow-up: Changed 5 years ago by dimpase

Replying to zimmerma:

thanks. I guess I have to type autoreconf -i before ./configure.

IMHO if you don't do this, the needed stuff will be fetched from the net.

comment:20 in reply to: ↑ 19 Changed 5 years ago by zimmerma

Replying to dimpase:

Replying to zimmerma:

thanks. I guess I have to type autoreconf -i before ./configure.

IMHO if you don't do this, the needed stuff will be fetched from the net.

since there is no configure file, only configure.ac, ./configure will fail.

comment:21 Changed 5 years ago by vbraun

The configure file is generate by the bootstrap script (standard stuff)

But you really only need to run "make", it will do the right thing even if you did not run bootstrap/configure yet.

comment:22 Changed 5 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer

comment:23 Changed 5 years ago by zimmerma

I confirm it works now with the git version (SageMath version 8.0.beta9).

1) I first tried without the Gap database, and I get the error:

verbose 0 (2061: permgroup_named.py, cardinality) Warning: TransitiveGroups requires the GAP database package. Please install it with ``sage -i database_gap``.

2) then I did sage -i database_gap, and then I get:

┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 8.0.beta9, Release Date: 2017-05-31               │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
┏━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┓
┃ Warning: this is a prerelease version, and it may be unstable.     ┃
┗━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┛
Forcing sage-location, probably because a new package was installed.
Updating various hardcoded paths...
(Please wait at most a few minutes.)
DO NOT INTERRUPT THIS.
Done updating paths.
sage: x = polygen(QQ); (x^5 - x - 1).galois_group()
Transitive group number 5 of degree 5

thus positive review on my side.

comment:24 Changed 5 years ago by jdemeyer

  • Reviewers changed from Jeroen Demeyer to Jeroen Demeyer, Paul Zimmermann
  • Status changed from needs_review to positive_review

comment:25 Changed 5 years ago by vbraun

  • Branch changed from u/vbraun/database_gap_doesn_t_work_after_installing_it to d76bfb23ecd68b9567e941e9fafcd0b00939f864
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.